summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-06-29 06:54:31 +0200
committerHans de Graaff <graaff@gentoo.org>2017-06-29 07:15:57 +0200
commitcded62752e7a75527bbe6522554f185afb37a7a3 (patch)
tree1e62b2a8b9f7c4324bfbf47c6f90e7fc97e58302 /dev-ruby/kramdown
parentdev-ruby/rouge: add ruby24 (diff)
downloadgentoo-cded62752e7a75527bbe6522554f185afb37a7a3.tar.gz
gentoo-cded62752e7a75527bbe6522554f185afb37a7a3.tar.bz2
gentoo-cded62752e7a75527bbe6522554f185afb37a7a3.zip
dev-ruby/kramdown: add 1.14.0
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/kramdown')
-rw-r--r--dev-ruby/kramdown/Manifest1
-rw-r--r--dev-ruby/kramdown/kramdown-1.14.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/kramdown/Manifest b/dev-ruby/kramdown/Manifest
index 2bf5fd567758..6634a274dad4 100644
--- a/dev-ruby/kramdown/Manifest
+++ b/dev-ruby/kramdown/Manifest
@@ -1,3 +1,4 @@
DIST kramdown-1.12.0.gem 243712 SHA256 603c6236ed7293def4020635e52fcc369a1488a47788c29f8aa0d90f4d19bfda SHA512 43d9e4b5fd2cd0e496f725b14c0a55b1f0db9274340909e01fd106ede3d3d5f2ec1ac1f3690a8951f7726bcc111e281ff3d28c0f488d2b4c508dc895af4c88af WHIRLPOOL 904678698c7594f529fadb9302f620f32daf3c31075447161c411b9c606e269fc73afd401a9ad301629f61544bd863ec0c51c86e6fc8c0da796f40f72966c927
DIST kramdown-1.13.1.gem 249856 SHA256 c497305953144a1c6001ebb2defb5368395aa804ab564f7e041f5293d2d9971c SHA512 2b791cfa223a8d55b6c6d39895f004af720fc5a95dcdf50d4ff0b72291aa590a5ae13a1084b395d953e643f0e6df9d94b5f42ac394b559bffcd0739cd60e99ad WHIRLPOOL f82e1896d3a95e07edc8c0fd54210e964ff29296a9d430785c33be541afbaa853129b58ea15afc324987eac57a628a79aea30219bfc15c99fa3c6b4ea63ba898
DIST kramdown-1.13.2.gem 249856 SHA256 2d11a7f9a9ec8dcf84e54af0a98b141a50a102b78e99b64e799f100c08c351c7 SHA512 dd2194184a7761bc490535a9d5631b78441b83f040e37dafc25b956dd680fe398d19ae75aff06dc2ec6a7573ac198169e175ef78a95743f0f7b4874bf28cebf8 WHIRLPOOL 7afe8437f9e24b4a5071a9031e67a871b2c6e0c4e66f5b3235eb345779bac382c6dab68de09f4e38749e517549e32b9b1cb188dbd88e46c09f082395a2b62585
+DIST kramdown-1.14.0.gem 250368 SHA256 f166820406ba92beeedb8cc496c1d1040cb237d5ad9d073b251e4a26562650a1 SHA512 bd6295db2fe0d3a7dca936d47f0aaf7f939a86361dfdd3203a52683a9eb11a68075cad7d068cc56a315db3c14e73cf5aebb87531ba3086301a7521c5a86f9905 WHIRLPOOL 8b2fe0cf3b7190b5640bcee3a03bdd0d688c4e2a3b2bc37efee3dbd84a2725a76f6e068fcf48600b96dbb654edcd22c93e59d3e83f1adb5a7cda2be6afc3f4a1
diff --git a/dev-ruby/kramdown/kramdown-1.14.0.ebuild b/dev-ruby/kramdown/kramdown-1.14.0.ebuild
new file mode 100644
index 000000000000..960481b618d8
--- /dev/null
+++ b/dev-ruby/kramdown/kramdown-1.14.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS CONTRIBUTERS"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser but fast, pure Ruby, using strict syntax definition"
+HOMEPAGE="http://kramdown.gettalong.org/"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE="latex"
+
+LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
+RDEPEND+=" ${LATEX_DEPS}"
+DEPEND+=" test? ( ${LATEX_DEPS} app-text/htmltidy )"
+
+ruby_add_rdepend "dev-ruby/prawn:2
+ >=dev-ruby/prawn-table-0.2.2 =dev-ruby/prawn-table-0.2*
+ >=dev-ruby/rouge-1.8:0
+ >=dev-ruby/itextomml-1.5
+ >=dev-ruby/coderay-1.0.0
+ >=dev-ruby/ritex-1.0
+ >=dev-ruby/stringex-1.5.1"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( >=dev-ruby/minitest-5.0 )"
+
+all_ruby_prepare() {
+ if ! use latex; then
+ # Remove latex tests. They will fail gracefully when latex isn't
+ # present at all, but not when components are missing (most
+ # notable ucs.sty).
+ sed -i -e '/latex -v/,/^ end/ s:^:#:' test/test_files.rb || die
+ fi
+
+ # Avoid tests requiring node to be installed with mathjaxnode.
+ rm -f test/testcases/span/math/mathjaxnode* \
+ test/testcases/block/15_math/mathjaxnode* || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/man1/kramdown.1
+}