summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/logue
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/logue')
-rw-r--r--dev-ruby/logue/Manifest1
-rw-r--r--dev-ruby/logue/logue-1.0.2-r1.ebuild30
-rw-r--r--dev-ruby/logue/logue-1.0.2-r2.ebuild30
-rw-r--r--dev-ruby/logue/metadata.xml8
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-ruby/logue/Manifest b/dev-ruby/logue/Manifest
new file mode 100644
index 000000000000..07b5913ae861
--- /dev/null
+++ b/dev-ruby/logue/Manifest
@@ -0,0 +1 @@
+DIST logue-git-1.0.2.tgz 17744 SHA256 ff8d454ce1801db9714864b76411ee3e44397ade0d078aaefcf5774827fb7ed0 SHA512 57ddc8dc2a31038aa231b8c0ac52218cc636f4767942c8c8aeec345f58de8b064522aabb4c958f39b9d67eab96d2f840ce16d00f71a6288589b28fbaa695ce0b WHIRLPOOL 2d8fce2ae38b0b42e007d125b090b21f1d46c43c3ac7e3537acacb5ef54e5c2ff3698141274793ceb2caa395aed8f53002cb0d8b3cec1763473be4056a261385
diff --git a/dev-ruby/logue/logue-1.0.2-r1.ebuild b/dev-ruby/logue/logue-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..28fcc610f3e4
--- /dev/null
+++ b/dev-ruby/logue/logue-1.0.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ruby22 -> code is not compatible.
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="Features.txt History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A module that adds logging/trace functionality"
+HOMEPAGE="https://github.com/jpace/logue"
+
+SRC_URI="https://github.com/jpace/logue/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 hppa ~ppc ~sparc x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rainbow-2.0.0"
+
+all_ruby_prepare() {
+ sed -i -e "s/run_test/do_run_test/" test/logue/testlog/log_stack_test.rb || die
+}
diff --git a/dev-ruby/logue/logue-1.0.2-r2.ebuild b/dev-ruby/logue/logue-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..6e4ef5fe3883
--- /dev/null
+++ b/dev-ruby/logue/logue-1.0.2-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ruby22 -> code is not compatible.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="Features.txt History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A module that adds logging/trace functionality"
+HOMEPAGE="https://github.com/jpace/logue"
+
+SRC_URI="https://github.com/jpace/logue/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rainbow-2.0.0"
+
+all_ruby_prepare() {
+ sed -i -e "s/run_test/do_run_test/" test/logue/testlog/log_stack_test.rb || die
+}
diff --git a/dev-ruby/logue/metadata.xml b/dev-ruby/logue/metadata.xml
new file mode 100644
index 000000000000..55a249775505
--- /dev/null
+++ b/dev-ruby/logue/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">jpace/logue</remote-id>
+ </upstream>
+</pkgmetadata>