summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/mail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/mail')
-rw-r--r--dev-ruby/mail/Manifest3
-rw-r--r--dev-ruby/mail/mail-2.5.4.ebuild39
-rw-r--r--dev-ruby/mail/mail-2.6.2.ebuild36
-rw-r--r--dev-ruby/mail/mail-2.6.3.ebuild34
-rw-r--r--dev-ruby/mail/metadata.xml8
5 files changed, 120 insertions, 0 deletions
diff --git a/dev-ruby/mail/Manifest b/dev-ruby/mail/Manifest
new file mode 100644
index 000000000000..7c2783bb1396
--- /dev/null
+++ b/dev-ruby/mail/Manifest
@@ -0,0 +1,3 @@
+DIST mail-2.5.4-git.tar.gz 833881 SHA256 d618fab11e0f4d308535a21bd6c59c2ab81a4ac864db830cc1817ad131512bb9 SHA512 5e042b9bff41e75af76b7d21275488f79b4c5e1821827b114bfc0d09b12b8c487189e4732e58a642621609fad48af381ae7cd5507f4fc5cb620f54a2288a6dda WHIRLPOOL 5013a057fd1cadd2f3ef5b1c4f8c62e476f36309ca6de935041b03986525a42969d4a7d57907eba4c6a5622d96cca269c3dfc37c14e1a45e4167a9b3d9d6ab50
+DIST mail-2.6.2-git.tar.gz 938380 SHA256 c1534307420972972803c3d37691df03e782da19e04efd5d7f20f142d3969d15 SHA512 db1febd70e94b0dc8e0b2a28eebe377163bcdbd0143880ae3e25d569e295b468344fcd65b1f892c6e3a70f48edf0a2ec78fb8d807712ba0354b7c1a5ace2cded WHIRLPOOL 1a16e4bde47fbf56efde4858c965490b3acca3d09519cb0e09f52b56a600442b77a79072bb62e61546a77a8c9faf9e7b86e35a07771818caab14e38ad51e7def
+DIST mail-2.6.3-git.tar.gz 940684 SHA256 0ba5d6bf4409c0c0a75bf7f7cd8f78c101a9a82109f760e0186e6cc24c60afff SHA512 02d54d68ff48f3d5a5a6430f7b5709b6fd9d37c7bc7ed1d0cb5b1f6120b8c03b6136a3f0e4cbfae01272dc6401300a2090d666277f2507d622e4dd98163d0ba7 WHIRLPOOL 42b0a93b1dc8bd8760a3414094528d140053f70a770d4319dda9be06a1779fe9bdb5e85b3778bf87138e894043b0e3ab0c7ae180241cdc7e73581ff1f3f78f88
diff --git a/dev-ruby/mail/mail-2.5.4.ebuild b/dev-ruby/mail/mail-2.5.4.ebuild
new file mode 100644
index 000000000000..828117459565
--- /dev/null
+++ b/dev-ruby/mail/mail-2.5.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.md ROADMAP TODO.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="mail.gemspec"
+
+inherit ruby-fakegem versionator
+
+GITHUB_USER="mikel"
+COMMIT="e8ec8d53c4f5c889691630d0422b9dc044762f1b"
+
+DESCRIPTION="An email handling library"
+HOMEPAGE="https://github.com/mikel/mail"
+SRC_URI="https://github.com/${GITHUB_USER}/mail/archive/${PV}.tar.gz -> ${P}-git.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/mime-types-1.16
+ >=dev-ruby/treetop-1.4.8"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undle/d' -e '6d' Rakefile || die "Unable to remove Bundler code."
+
+ # Fix up dependencies to match our own.
+ sed -i -e 's/~>/>=/' mail.gemspec || die "Unable to fix up dependencies."
+}
diff --git a/dev-ruby/mail/mail-2.6.2.ebuild b/dev-ruby/mail/mail-2.6.2.ebuild
new file mode 100644
index 000000000000..094a74153f70
--- /dev/null
+++ b/dev-ruby/mail/mail-2.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.md ROADMAP TODO.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+RUBY_FAKEGEM_GEMSPEC="mail.gemspec"
+
+inherit ruby-fakegem versionator
+
+GITHUB_USER="mikel"
+
+DESCRIPTION="An email handling library"
+HOMEPAGE="https://github.com/mikel/mail"
+SRC_URI="https://github.com/${GITHUB_USER}/mail/archive/${PV}.tar.gz -> ${P}-git.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/mime-types-1.16 <dev-ruby/mime-types-3"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undle/d' -e '6d' Rakefile || die "Unable to remove Bundler code."
+}
diff --git a/dev-ruby/mail/mail-2.6.3.ebuild b/dev-ruby/mail/mail-2.6.3.ebuild
new file mode 100644
index 000000000000..89cefa8db50e
--- /dev/null
+++ b/dev-ruby/mail/mail-2.6.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.md ROADMAP TODO.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="mail.gemspec"
+
+inherit ruby-fakegem versionator
+
+GITHUB_USER="mikel"
+
+DESCRIPTION="An email handling library"
+HOMEPAGE="https://github.com/mikel/mail"
+SRC_URI="https://github.com/${GITHUB_USER}/mail/archive/${PV}.tar.gz -> ${P}-git.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/mime-types-1.16 <dev-ruby/mime-types-3"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undle/d' -e '6d' Rakefile || die "Unable to remove Bundler code."
+}
diff --git a/dev-ruby/mail/metadata.xml b/dev-ruby/mail/metadata.xml
new file mode 100644
index 000000000000..c3f3bd3eecbd
--- /dev/null
+++ b/dev-ruby/mail/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">mikel/mail</remote-id>
+ </upstream>
+</pkgmetadata>