summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-01-15 07:46:20 +0100
committerHans de Graaff <graaff@gentoo.org>2017-01-15 07:46:20 +0100
commitf226efa9eef528adc1337fecc001d418a599ec7c (patch)
tree80737fb22771fd60ec4643493d961c8b26b4823f /dev-ruby/maruku/maruku-0.7.3.ebuild
parentmedia-libs/gst-plugins-base: Remove now unused opus local USE flag definition (diff)
downloadgentoo-f226efa9eef528adc1337fecc001d418a599ec7c.tar.gz
gentoo-f226efa9eef528adc1337fecc001d418a599ec7c.tar.bz2
gentoo-f226efa9eef528adc1337fecc001d418a599ec7c.zip
dev-ruby/maruku: add 0.7.3
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/maruku/maruku-0.7.3.ebuild')
-rw-r--r--dev-ruby/maruku/maruku-0.7.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/maruku/maruku-0.7.3.ebuild b/dev-ruby/maruku/maruku-0.7.3.ebuild
new file mode 100644
index 000000000000..f15c0d826263
--- /dev/null
+++ b/dev-ruby/maruku/maruku-0.7.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="docs/div_syntax.md docs/entity_test.md
+ docs/markdown_syntax.md docs/maruku.md docs/math.md docs/other_stuff.md
+ docs/proposal.md"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Markdown-superset interpreter written in Ruby"
+HOMEPAGE="https://github.com/bhollis/maruku"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="highlight test"
+
+ruby_add_bdepend "test? ( dev-ruby/nokogiri-diff )"
+ruby_add_rdepend "highlight? ( dev-ruby/syntax )"
+
+DEPEND+=" test? ( app-text/blahtexml )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' spec/spec_helper.rb || die
+}
+
+pkg_postinst() {
+ elog
+ elog "You need to emerge app-text/texlive and dev-texlive/texlive-latexextra if"
+ elog "you want to use --pdf with Maruku. You may also want to emerge"
+ elog "dev-texlive/texlive-latexrecommended to enable LaTeX syntax highlighting."
+ elog
+}