summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-10-24 22:05:09 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-10-24 22:05:09 +0200
commit9f47cf11957a0b1d8e4c49c9882bb400be8dd574 (patch)
tree69cacec9e356c2e775a2fe28dd98c48eb6f67b38 /dev-ruby/mixlib-shellout/mixlib-shellout-2.2.7.ebuild
parentx11-drivers/xf86-video-intel: Remove old (diff)
downloadgentoo-9f47cf11957a0b1d8e4c49c9882bb400be8dd574.tar.gz
gentoo-9f47cf11957a0b1d8e4c49c9882bb400be8dd574.tar.bz2
gentoo-9f47cf11957a0b1d8e4c49c9882bb400be8dd574.zip
dev-ruby/mixlib-shellout: Version bump to 2.2.7
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ruby/mixlib-shellout/mixlib-shellout-2.2.7.ebuild')
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-2.2.7.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-2.2.7.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-2.2.7.ebuild
new file mode 100644
index 000000000000..4b84f8033293
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-2.2.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRA_DOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="https://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+}