summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-29 07:18:18 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-29 07:42:06 +0200
commit22ea101fb26ee7c2ec281e82710b7ccf061d5518 (patch)
treec7f8c44f0c6aca1c3fac26ead0409c61c57b865f /dev-ruby/mixlib-shellout/mixlib-shellout-2.3.2.ebuild
parentmedia-gfx/feh: version bump to 2.19.1 (diff)
downloadgentoo-22ea101fb26ee7c2ec281e82710b7ccf061d5518.tar.gz
gentoo-22ea101fb26ee7c2ec281e82710b7ccf061d5518.tar.bz2
gentoo-22ea101fb26ee7c2ec281e82710b7ccf061d5518.zip
dev-ruby/mixlib-shellout: add 2.3.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/mixlib-shellout/mixlib-shellout-2.3.2.ebuild')
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-2.3.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-2.3.2.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-2.3.2.ebuild
new file mode 100644
index 000000000000..adcdf80bf37e
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-2.3.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRA_DOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="https://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+}