summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-01-05 08:41:40 +0100
committerHans de Graaff <graaff@gentoo.org>2020-01-05 08:41:40 +0100
commitc24a75cb835143b30e1e7c2fc720e12038a13983 (patch)
tree89fd65eac49cc7895308110d012741cb5d44fc9b /dev-ruby/mocha/mocha-1.11.2.ebuild
parentdev-ruby/mocha: cleanup (diff)
downloadgentoo-c24a75cb835143b30e1e7c2fc720e12038a13983.tar.gz
gentoo-c24a75cb835143b30e1e7c2fc720e12038a13983.tar.bz2
gentoo-c24a75cb835143b30e1e7c2fc720e12038a13983.zip
dev-ruby/mocha: add 1.11.2
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/mocha/mocha-1.11.2.ebuild')
-rw-r--r--dev-ruby/mocha/mocha-1.11.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/mocha/mocha-1.11.2.ebuild b/dev-ruby/mocha/mocha-1.11.2.ebuild
new file mode 100644
index 000000000000..a08aefa4197a
--- /dev/null
+++ b/dev-ruby/mocha/mocha-1.11.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="test:units test:acceptance"
+
+RUBY_FAKEGEM_EXTRADOC="README.md RELEASE.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mocking and stubbing using a syntax like that of JMock and SchMock"
+HOMEPAGE="https://mocha.jamesmead.org/"
+
+LICENSE="MIT"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "
+ test? ( >=dev-ruby/test-unit-2.5.1-r1 dev-ruby/introspection )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
+}
+
+each_ruby_test() {
+ export MOCHA_NO_DOCS=true
+ each_fakegem_test
+}