summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/mongo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/mongo')
-rw-r--r--dev-ruby/mongo/Manifest1
-rw-r--r--dev-ruby/mongo/metadata.xml8
-rw-r--r--dev-ruby/mongo/mongo-1.12.0.ebuild68
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-ruby/mongo/Manifest b/dev-ruby/mongo/Manifest
new file mode 100644
index 000000000000..d8235c02f46e
--- /dev/null
+++ b/dev-ruby/mongo/Manifest
@@ -0,0 +1 @@
+DIST mongo-ruby-driver-1.12.0.tar.gz 360669 SHA256 84c87d26601c9bd91a6604bcb3630be50d239e471542f9b0a68379705dd03e11 SHA512 725110c527867379def85fde50b6825e94a320356f062e4403d9d55c223f2503676f83ae42916d6ab45afd90d30b2a4272519e070c4af2095c0965297fd72bb6 WHIRLPOOL c152aa579a0535707909560cc73fc878521aac95c034ec71bca6c2397754b5e057c1e7ca32f6b2b3393ce975f122e65926820cdde29aa5f5734fb9717bd980e0
diff --git a/dev-ruby/mongo/metadata.xml b/dev-ruby/mongo/metadata.xml
new file mode 100644
index 000000000000..fdcb13295195
--- /dev/null
+++ b/dev-ruby/mongo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">mongodb/mongo-ruby-driver</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/mongo/mongo-1.12.0.ebuild b/dev-ruby/mongo/mongo-1.12.0.ebuild
new file mode 100644
index 000000000000..243c46aa2f0d
--- /dev/null
+++ b/dev-ruby/mongo/mongo-1.12.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+GITHUB_USER="mongodb"
+GITHUB_PROJECT="mongo-ruby-driver"
+RUBY_S="${GITHUB_PROJECT}-${PV}"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby driver for MongoDB"
+HOMEPAGE="http://www.mongodb.org/"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/${PV}.tar.gz -> ${GITHUB_PROJECT}-${PV}.tar.gz"
+
+LICENSE="APSL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# This is the same source package as bson, so keep them the same
+# version, but not revision
+ruby_add_rdepend "~dev-ruby/bson-${PV}"
+
+ruby_add_bdepend \
+ "test? (
+ dev-ruby/bundler
+ >=dev-ruby/rake-10.1
+ dev-ruby/sfl
+ >=dev-ruby/shoulda-3.3.2
+ dev-ruby/mocha
+ dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ # remove the stuff that is actually part of dev-ruby/bson
+ rm -f bin/{b2j,j2b}son || die
+
+ # Avoid test dependency on pry
+ sed -i -e '/\(pry\|coverall\)/I s:^:#:' Gemfile tasks/testing.rake test/test_helper.rb || die
+ # Avoid deployment dependencies and fix version issues
+ sed -i -e '/rest-client/ s/1.6.8/~> 1.6/' \
+ -e '/test-unit/ s/~>2.0/>= 2.0/' \
+ -e '/rake/ s/10.1.1/~>10.1/' \
+ -e '/:deploy/,/end/ s:^:#:' Gemfile || die
+}
+
+each_ruby_test() {
+ JENKINS_CI=true ${RUBY} -S rake test:unit || die "Tests failed."
+}
+
+each_ruby_install() {
+ # Remove bson code used for testing. This is installed as part of
+ # dev-ruby/bson.
+ rm -rf lib/bson* || die
+
+ each_fakegem_install
+}