summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-10-17 07:21:30 +0200
committerHans de Graaff <graaff@gentoo.org>2016-10-17 07:21:30 +0200
commitf99d86728b040d50d335425ae4bd3d29e1ebd037 (patch)
tree53d2e0b1f9aa3cfcdbfc8cda8e377032e44432e7 /dev-ruby/msgpack/msgpack-1.0.1.ebuild
parentapp-emulation/rkt: remove old versions (diff)
downloadgentoo-f99d86728b040d50d335425ae4bd3d29e1ebd037.tar.gz
gentoo-f99d86728b040d50d335425ae4bd3d29e1ebd037.tar.bz2
gentoo-f99d86728b040d50d335425ae4bd3d29e1ebd037.zip
dev-ruby/msgpack: add 1.0.1
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/msgpack/msgpack-1.0.1.ebuild')
-rw-r--r--dev-ruby/msgpack/msgpack-1.0.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/msgpack/msgpack-1.0.1.ebuild b/dev-ruby/msgpack/msgpack-1.0.1.ebuild
new file mode 100644
index 000000000000..fc0ae75af735
--- /dev/null
+++ b/dev-ruby/msgpack/msgpack-1.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
+HOMEPAGE="http://msgpack.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86-fbsd"
+IUSE="doc"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove jruby-specific specs that are run also for other rubies.
+ rm -rf spec/jruby || die
+
+ sed -i -e '/git ls-files/d' msgpack.gemspec || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die "Configuration of extension failed."
+
+ # rb_num2int is not inlined on 32 bit arches but also not explicitly
+ # defined, bug 582968
+ sed -i -e 's:-Wl,--no-undefined::' ext/${PN}/Makefile || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/msgpack$(get_modname) lib/${PN} || die "Unable to install msgpack library."
+}