summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-03-07 06:46:43 +0100
committerHans de Graaff <graaff@gentoo.org>2017-03-07 06:46:43 +0100
commita0da146811f71ca1a708f51bf61951731cbbba59 (patch)
tree3773c036596f0c248494d2192744c1422ab52eb5 /dev-ruby/msgpack/msgpack-1.1.0.ebuild
parentdev-ruby/psych: add 2.2.4 (diff)
downloadgentoo-a0da146811f71ca1a708f51bf61951731cbbba59.tar.gz
gentoo-a0da146811f71ca1a708f51bf61951731cbbba59.tar.bz2
gentoo-a0da146811f71ca1a708f51bf61951731cbbba59.zip
dev-ruby/msgpack: add 1.1.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/msgpack/msgpack-1.1.0.ebuild')
-rw-r--r--dev-ruby/msgpack/msgpack-1.1.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/msgpack/msgpack-1.1.0.ebuild b/dev-ruby/msgpack/msgpack-1.1.0.ebuild
new file mode 100644
index 000000000000..08bed06564e4
--- /dev/null
+++ b/dev-ruby/msgpack/msgpack-1.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
+HOMEPAGE="https://msgpack.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~x86-fbsd"
+IUSE="doc"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove jruby-specific specs that are run also for other rubies.
+ rm -rf spec/jruby || die
+
+ sed -i -e '/git ls-files/d' msgpack.gemspec || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die "Configuration of extension failed."
+
+ # rb_num2int is not inlined on 32 bit arches but also not explicitly
+ # defined, bug 582968
+ sed -i -e 's:-Wl,--no-undefined::' ext/${PN}/Makefile || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/msgpack$(get_modname) lib/${PN} || die "Unable to install msgpack library."
+}