summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-05-19 06:56:28 +0200
committerHans de Graaff <graaff@gentoo.org>2016-05-19 07:29:48 +0200
commit780f1ca6b72e03443dca98ac7d121706958eb46b (patch)
treed602c8b89933678b3de050f742b2bb1dfb2840d6 /dev-ruby/multi_json/multi_json-1.12.1.ebuild
parentdev-ruby/maxitest: add 2.0.1 (diff)
downloadgentoo-780f1ca6b72e03443dca98ac7d121706958eb46b.tar.gz
gentoo-780f1ca6b72e03443dca98ac7d121706958eb46b.tar.bz2
gentoo-780f1ca6b72e03443dca98ac7d121706958eb46b.zip
dev-ruby/multi_json: add 1.12.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/multi_json/multi_json-1.12.1.ebuild')
-rw-r--r--dev-ruby/multi_json/multi_json-1.12.1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/multi_json/multi_json-1.12.1.ebuild b/dev-ruby/multi_json/multi_json-1.12.1.ebuild
new file mode 100644
index 000000000000..5b6038b57d7e
--- /dev/null
+++ b/dev-ruby/multi_json/multi_json-1.12.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/intridea/multi_json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="https://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-1.0 =dev-ruby/activesupport-3* )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec:3 dev-ruby/yard )"
+
+ruby_add_bdepend "test? ( dev-ruby/json
+ dev-ruby/yajl-ruby )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die "Unable to remove bundler."
+
+ # Remove unimportant rspec options not supported by rspec 2.6.
+ rm .rspec || die
+
+ # Remove specs specific to oj since we don't package oj yet.
+ sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' \
+ -e '/Oj does not create symbols on parse/,/^ end/ s:^:#:' \
+ -e '/with Oj.default_settings/,/^ end/ s:^:#:' \
+ -e '/using one-shot parser/,/^ end/ s:^:#:' \
+ spec/multi_json_spec.rb
+
+ # Avoid simplecov which only works with ruby 1.9
+ sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/spec_helper.rb || die
+
+ # Remove unpackaged and for our purposes unneeded coveralls
+ sed -i -e '/coveralls/d' spec/spec_helper.rb || die
+
+ # Avoid testing unpackaged adapters
+ rm spec/{gson,jr_jackson,oj}_adapter_spec.rb || die
+}
+
+each_ruby_test() {
+ for t in spec/*_spec.rb; do
+ ${RUBY} -S rspec-3 ${t} || die
+ done
+}