summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-28 13:02:06 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-08-28 13:17:23 +0200
commit1023b00a2f872c4a56459e384d1e34a2cbec2ef7 (patch)
tree35b0b9e90456fbc381c2011544b4d061dfb84024 /dev-ruby/mysql2/mysql2-0.5.1.ebuild
parentgnustep-libs/sope: rev bump to ease migration to dev-db/mysql-connector-c (diff)
downloadgentoo-1023b00a2f872c4a56459e384d1e34a2cbec2ef7.tar.gz
gentoo-1023b00a2f872c4a56459e384d1e34a2cbec2ef7.tar.bz2
gentoo-1023b00a2f872c4a56459e384d1e34a2cbec2ef7.zip
dev-ruby/mysql2: rev bump to ease migration to dev-db/mysql-connector-c
Commit 66bf25c026c2c6136cc99b2c2657f46d0c790f10 replaced virtual/libmysqlclient dependency with dev-db/mysql-connector-c atom without a rev bump. To avoid unecessary user interaction for users not using emerge's --changed-deps=y because we are already pushing towards removal of virtual/libmysqlclient (see commit 08b83d736f77fd5dffa9cd5f6b1b44771726ce94), this commit will now force the re-installation through rev bump to ease migration. Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-ruby/mysql2/mysql2-0.5.1.ebuild')
-rw-r--r--dev-ruby/mysql2/mysql2-0.5.1.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-ruby/mysql2/mysql2-0.5.1.ebuild b/dev-ruby/mysql2/mysql2-0.5.1.ebuild
deleted file mode 100644
index c9ce68fd9891..000000000000
--- a/dev-ruby/mysql2/mysql2-0.5.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
-
-# Tests require a live MySQL database but should all pass.
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A modern, simple and very fast Mysql library for Ruby - binding to libmysql"
-HOMEPAGE="https://github.com/brianmario/mysql2"
-
-LICENSE="MIT"
-SLOT="0.5"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE=""
-
-DEPEND="${DEPEND} dev-db/mysql-connector-c"
-RDEPEND="${RDEPEND} dev-db/mysql-connector-c:="
-
-each_ruby_configure() {
- ${RUBY} -Cext/mysql2 extconf.rb --with-mysql-config "${EPREFIX}/usr/bin/mysqlconfig" || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/mysql2
- cp ext/mysql2/mysql2$(get_modname) lib/mysql2/ || die
-}