summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-07-13 10:57:03 +0200
committerHans de Graaff <graaff@gentoo.org>2021-07-13 11:20:48 +0200
commit7d4d4d23ab016ceb30ec48244e110baa2ee16297 (patch)
treedc986b7a1bd6ed8e621b4995d65d21829be527db /dev-ruby/nanotest
parentdev-util/cucumber-gherkin: initial import of 18.1.1 (diff)
downloadgentoo-7d4d4d23ab016ceb30ec48244e110baa2ee16297.tar.gz
gentoo-7d4d4d23ab016ceb30ec48244e110baa2ee16297.tar.bz2
gentoo-7d4d4d23ab016ceb30ec48244e110baa2ee16297.zip
dev-ruby/nanotest: add ruby30; EAPI 7
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/nanotest')
-rw-r--r--dev-ruby/nanotest/nanotest-0.9.4.1-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ruby/nanotest/nanotest-0.9.4.1-r1.ebuild b/dev-ruby/nanotest/nanotest-0.9.4.1-r1.ebuild
new file mode 100644
index 000000000000..b9be42e26654
--- /dev/null
+++ b/dev-ruby/nanotest/nanotest-0.9.4.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extremely mynymal test framework"
+HOMEPAGE="https://github.com/mynyml/nanotest"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -I.:lib test/test_nanotest.rb || die
+}