summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-06-04 06:07:35 +0200
committerHans de Graaff <graaff@gentoo.org>2020-06-04 06:07:35 +0200
commitfeccf498df0026926ee1e9f5a8104836068ff804 (patch)
tree37d711831ba877136c9ded82f9b3a5844bb8b5e1 /dev-ruby/net-http-persistent/net-http-persistent-4.0.0.ebuild
parentdev-python/nautilus-python: Version bump to 1.2.3 (diff)
downloadgentoo-feccf498df0026926ee1e9f5a8104836068ff804.tar.gz
gentoo-feccf498df0026926ee1e9f5a8104836068ff804.tar.bz2
gentoo-feccf498df0026926ee1e9f5a8104836068ff804.zip
dev-ruby/net-http-persistent: add 4.0.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/net-http-persistent/net-http-persistent-4.0.0.ebuild')
-rw-r--r--dev-ruby/net-http-persistent/net-http-persistent-4.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/net-http-persistent/net-http-persistent-4.0.0.ebuild b/dev-ruby/net-http-persistent/net-http-persistent-4.0.0.ebuild
new file mode 100644
index 000000000000..6aaaac32ee1a
--- /dev/null
+++ b/dev-ruby/net-http-persistent/net-http-persistent-4.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Manages persistent connections using Net::HTTP plus a speed fix for Ruby 1.8"
+HOMEPAGE="https://github.com/drbrain/net-http-persistent"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/connection_pool-2.2:0"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/hoe dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # avoid test with implicit dependency on net-http-pipeline which
+ # fails and is not tested upstream
+ sed -i -e '/net-http-pipeline not installed/ s/unless.*$//' test/test_net_http_persistent.rb || die
+}