summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-02-13 09:05:19 +0100
committerHans de Graaff <graaff@gentoo.org>2022-02-13 10:06:07 +0100
commitf148836a6ae57c3a2bdb2ba1219f802624ab14e1 (patch)
tree7997d2194af3f8d177bd4edda8e5106650f05f85 /dev-ruby/net-pop
parentdev-ruby/net-smtp: import 0.3.1 (diff)
downloadgentoo-f148836a6ae57c3a2bdb2ba1219f802624ab14e1.tar.gz
gentoo-f148836a6ae57c3a2bdb2ba1219f802624ab14e1.tar.bz2
gentoo-f148836a6ae57c3a2bdb2ba1219f802624ab14e1.zip
dev-ruby/net-pop: import 0.1.1
Extracted from dev-lang/ruby, keywords have been migrated. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/net-pop')
-rw-r--r--dev-ruby/net-pop/Manifest1
-rw-r--r--dev-ruby/net-pop/metadata.xml11
-rw-r--r--dev-ruby/net-pop/net-pop-0.1.1.ebuild33
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/net-pop/Manifest b/dev-ruby/net-pop/Manifest
new file mode 100644
index 000000000000..5a8ef422b0f3
--- /dev/null
+++ b/dev-ruby/net-pop/Manifest
@@ -0,0 +1 @@
+DIST net-pop-0.1.1.tar.gz 17292 BLAKE2B ccb653929b29572944b0edfd1d8123c64fd1e2baabf360ed9d04a173d348825d2a2c1e675669af96e11c84cd32a07ad37a395e9a5a78bd8a853c65e42d1dd205 SHA512 9a6a03cf8ce19711a1f9318910f0cb01ec5282695e986b68657fafc289ef32c084f2a9f5a038114f550ef1553bc99c8dda094191492b503c82a37a4a71124eb2
diff --git a/dev-ruby/net-pop/metadata.xml b/dev-ruby/net-pop/metadata.xml
new file mode 100644
index 000000000000..ae944adb3a9c
--- /dev/null
+++ b/dev-ruby/net-pop/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/net-pop</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/net-pop/net-pop-0.1.1.ebuild b/dev-ruby/net-pop/net-pop-0.1.1.ebuild
new file mode 100644
index 000000000000..711764cf3b71
--- /dev/null
+++ b/dev-ruby/net-pop/net-pop-0.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="net-pop.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby client library for POP3"
+HOMEPAGE="https://github.com/ruby/net-pop"
+SRC_URI="https://github.com/ruby/net-pop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/digest
+ dev-ruby/net-protocol
+ dev-ruby/timeout
+"
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}