summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/net-scp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/net-scp')
-rw-r--r--dev-ruby/net-scp/Manifest2
-rw-r--r--dev-ruby/net-scp/metadata.xml8
-rw-r--r--dev-ruby/net-scp/net-scp-1.1.2-r1.ebuild32
-rw-r--r--dev-ruby/net-scp/net-scp-1.2.1.ebuild33
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-ruby/net-scp/Manifest b/dev-ruby/net-scp/Manifest
new file mode 100644
index 000000000000..3bca654f2b89
--- /dev/null
+++ b/dev-ruby/net-scp/Manifest
@@ -0,0 +1,2 @@
+DIST net-scp-1.1.2.gem 32256 SHA256 f3d8848f63f9b7670e57af2e2c308e9bd6fddb7c5440a36e892478a1e62b5977 SHA512 5ba49a994a816b54aee32b5c3e708bed69fc22d7e688f60e93a1e2d29d086ed17f3685ea819d5db23a27abf8ba64fbd418204e1a1702fb0d2702607016febc09 WHIRLPOOL 08573792d16f1719ffbeabb621c4148823f649de43c8a0e8bea2506c329a3c653d21483113fa290022f3cfdd40713ac577d7816f2c77458dab5a80cf115432bd
+DIST net-scp-1.2.1.gem 32768 SHA256 928ca046246bdbfe304313c903bab95e7b711938ceff4a2c896b91ab59c6122c SHA512 64645a4517d6e408e3acfdb24576c8ded3b6ff981035ca10a2e081f9e3ab093f97b4848da4acca03ade364483766677e31296d09a31db4c81eb40123fc966829 WHIRLPOOL 5adcb5746acc9e1fd8f19718c532c7192896d239b8240522e3df67d60e05550b9bd2360996b2343d9cab5dea643ada2d3c0bcc149753dcc5c1eb20e90d883f8c
diff --git a/dev-ruby/net-scp/metadata.xml b/dev-ruby/net-scp/metadata.xml
new file mode 100644
index 000000000000..be5f4778d303
--- /dev/null
+++ b/dev-ruby/net-scp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">net-ssh/net-scp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/net-scp/net-scp-1.1.2-r1.ebuild b/dev-ruby/net-scp/net-scp-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..45ca33d2d6d9
--- /dev/null
+++ b/dev-ruby/net-scp/net-scp-1.1.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby implementation of the SCP client protocol"
+HOMEPAGE="http://net-ssh.rubyforge.org/scp"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/net-ssh-2.6.5 )
+ test? (
+ dev-ruby/mocha
+ )"
+
+ruby_add_rdepend ">=dev-ruby/net-ssh-2.6.5"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/test_all.rb || die
+}
diff --git a/dev-ruby/net-scp/net-scp-1.2.1.ebuild b/dev-ruby/net-scp/net-scp-1.2.1.ebuild
new file mode 100644
index 000000000000..7a386aa57af6
--- /dev/null
+++ b/dev-ruby/net-scp/net-scp-1.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby implementation of the SCP client protocol"
+HOMEPAGE="https://github.com/net-ssh/net-scp"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/net-ssh-2.6.5 )
+ test? (
+ >=dev-ruby/net-ssh-2.9.0
+ dev-ruby/mocha
+ )"
+
+ruby_add_rdepend ">=dev-ruby/net-ssh-2.6.5"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/test_all.rb || die
+}