summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-23 12:39:38 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-24 07:37:11 +0100
commitd436ca97b35e6494acab7172cd9e926b5beb933b (patch)
treede61bb3d6c1ededc568bc28d384039a960d34e1f /dev-ruby/niceogiri
parentdev-ruby/uconv: add ruby30 (diff)
downloadgentoo-d436ca97b35e6494acab7172cd9e926b5beb933b.tar.gz
gentoo-d436ca97b35e6494acab7172cd9e926b5beb933b.tar.bz2
gentoo-d436ca97b35e6494acab7172cd9e926b5beb933b.zip
dev-ruby/niceogiri: add ruby30
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/niceogiri')
-rw-r--r--dev-ruby/niceogiri/niceogiri-1.1.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/niceogiri/niceogiri-1.1.2-r1.ebuild b/dev-ruby/niceogiri/niceogiri-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..b8daa104730c
--- /dev/null
+++ b/dev-ruby/niceogiri/niceogiri-1.1.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Some wrappers around and helpers for XML manipulation using Nokogiri"
+HOMEPAGE="https://github.com/benlangfeld/Niceogiri"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/nokogiri"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i -e '/guard-rspec/d' ${PN}.gemspec || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+}