summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-12-01 07:14:47 +0100
committerHans de Graaff <graaff@gentoo.org>2023-12-01 07:14:47 +0100
commitea256b3b7f30f7c33e606c2f7a375a7216591e08 (patch)
tree5eb819bb7445d56beab263d7903b8d1737768055 /dev-ruby/nio4r/nio4r-2.7.0.ebuild
parentdev-ruby/net-imap: drop 0.4.1 (diff)
downloadgentoo-ea256b3b7f30f7c33e606c2f7a375a7216591e08.tar.gz
gentoo-ea256b3b7f30f7c33e606c2f7a375a7216591e08.tar.bz2
gentoo-ea256b3b7f30f7c33e606c2f7a375a7216591e08.zip
dev-ruby/nio4r: add 2.7.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/nio4r/nio4r-2.7.0.ebuild')
-rw-r--r--dev-ruby/nio4r/nio4r-2.7.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/nio4r/nio4r-2.7.0.ebuild b/dev-ruby/nio4r/nio4r-2.7.0.ebuild
new file mode 100644
index 000000000000..381b1a8e8790
--- /dev/null
+++ b/dev-ruby/nio4r/nio4r-2.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_EXTRADOC="changes.md readme.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/nio4r/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance selector API for monitoring IO objects"
+HOMEPAGE="https://github.com/socketry/nio4r"
+
+LICENSE="MIT || ( BSD GPL-2 )"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+# Note that nio4r bundles a patched copy of libev, and without these
+# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' spec/spec_helper.rb || die
+ sed -e '/extension/ s:^:#:' -i Rakefile || die
+}