summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-12-28 07:51:11 +0100
committerHans de Graaff <graaff@gentoo.org>2016-12-28 07:51:11 +0100
commitd885792aeb2d70e0ae3b8703f2515266c35cd760 (patch)
treec6c54deefe6075e816fb26346bd18e684312e168 /dev-ruby/oauth2
parentdev-ruby/oauth2: cleanup (diff)
downloadgentoo-d885792aeb2d70e0ae3b8703f2515266c35cd760.tar.gz
gentoo-d885792aeb2d70e0ae3b8703f2515266c35cd760.tar.bz2
gentoo-d885792aeb2d70e0ae3b8703f2515266c35cd760.zip
dev-ruby/oauth2: add 1.3.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/Manifest1
-rw-r--r--dev-ruby/oauth2/oauth2-1.3.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/oauth2/Manifest b/dev-ruby/oauth2/Manifest
index d2036b144e73..61863f7df195 100644
--- a/dev-ruby/oauth2/Manifest
+++ b/dev-ruby/oauth2/Manifest
@@ -1 +1,2 @@
DIST oauth2-1.2.0.tar.gz 18949 SHA256 e40fb1edaac68cb83bdbd1d6e2a1c485535278124c48f7b2db4771bb03c927d0 SHA512 2adacdc02752289eba217c6b2dfce0d00325becdbb7983b9fdfb149717ffd58cd235217048e48dc5be3d3c4024c224f8164cb0f9b4d792060554fbcb72e70536 WHIRLPOOL 138076cf3509b08ba40041be126d158ebd1767f043c0838789d28b5bce63b6c5ee49c2acfcf9ce81b9cc0303f618035366e947bc4bbd6e242658e973438cf5fc
+DIST oauth2-1.3.0.tar.gz 20739 SHA256 fc3c1c5d540a7dbf5363a753052394eb67397590e17b15c1daf2d214ef3a5eaf SHA512 18b7a5055bdbecd1a073b0c7e4f9175b70cf0b6df0f98811d7de4a3ff252b9d2e6319cc3c9d9c3564cfe45a96bbd55a1cf0658dd8080918fc03b14e0f0041c9d WHIRLPOOL b5ad6772fd033342585ba03fd0cbf3a1bd74876ff2027f80e7550f9a50d464d5d89b6b570b7949ffc929fbd36ebe389dbfa8e543e78b8f565546a9cb974c0842
diff --git a/dev-ruby/oauth2/oauth2-1.3.0.ebuild b/dev-ruby/oauth2/oauth2-1.3.0.ebuild
new file mode 100644
index 000000000000..ff3d289bdd3d
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-1.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
+HOMEPAGE="https://github.com/intridea/oauth2"
+SRC_URI="https://github.com/intridea/oauth2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/faraday-0.8
+ >=dev-ruby/jwt-1.0 =dev-ruby/jwt-1*
+ >=dev-ruby/multi_json-1.3 =dev-ruby/multi_json-1*
+ >=dev-ruby/multi_xml-0.5:0
+ >=dev-ruby/rack-1.2:* <dev-ruby/rack-3:*"
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^ end/ s:^:#:' spec/helper.rb || die
+
+ sed -i -e '/yardstick/,/^end/ s:^:#:' \
+ -e '/bundler/I s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec spec || die
+}