summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-26 09:45:50 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-26 11:49:32 +0200
commit46f51d8dec299e53f0ac914c98517558ab8bf371 (patch)
treeaa4da4a6e81594eb60bbafcb8a82d766b17833d6 /dev-ruby/oauth
parentdev-ruby/rest-client: EAPI 7 -> 8, add ruby30 (diff)
downloadgentoo-46f51d8dec299e53f0ac914c98517558ab8bf371.tar.gz
gentoo-46f51d8dec299e53f0ac914c98517558ab8bf371.tar.bz2
gentoo-46f51d8dec299e53f0ac914c98517558ab8bf371.zip
dev-ruby/oauth: fix tests
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/oauth-0.5.10.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-ruby/oauth/oauth-0.5.10.ebuild b/dev-ruby/oauth/oauth-0.5.10.ebuild
index 6aacd85e42e9..d2a781ddc4e8 100644
--- a/dev-ruby/oauth/oauth-0.5.10.ebuild
+++ b/dev-ruby/oauth/oauth-0.5.10.ebuild
@@ -32,8 +32,14 @@ ruby_add_bdepend "test? (
all_ruby_prepare() {
# Require a compatible version of mocha
- sed -i -e '1igem "mocha", "~> 1.0"; gem "railties", "~>6.1.0" ; gem "actionpack", "~>6.1.0"' \
- -e '2i gem "test-unit"; require "test/unit"' \
+ sed -i -e '1igem "mocha", "~> 1.0"; gem "railties", "~>6.1.0" ; gem "actionpack", "~>6.1.0"; require "action_dispatch"' \
-e '/mocha/ s/mini_test/minitest/' \
-e '/\(byebug\|minitest_helpers\|simplecov\)/I s:^:#:' test/test_helper.rb || die
+
+ # Avoid test tripped up by kwargs confusion
+ sed -i -e '/test_authorize/askip "kwargs confusion"' test/units/test_cli.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/**/*test*.rb"].each {|f| require f}' || die
}