summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-02-06 07:30:22 +0100
committerHans de Graaff <graaff@gentoo.org>2018-02-07 07:30:27 +0100
commitdf37634af2e438eaf477c79cca566f06b526327d (patch)
tree227e6d45fb8367f902119a2d71c90e0348b1483b /dev-ruby/oauth
parentdev-ruby/ntlm-http: add ruby25 (diff)
downloadgentoo-df37634af2e438eaf477c79cca566f06b526327d.tar.gz
gentoo-df37634af2e438eaf477c79cca566f06b526327d.tar.bz2
gentoo-df37634af2e438eaf477c79cca566f06b526327d.zip
dev-ruby/oauth: cleanup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/Manifest1
-rw-r--r--dev-ruby/oauth/oauth-0.5.1.ebuild44
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-ruby/oauth/Manifest b/dev-ruby/oauth/Manifest
index 37d6321381b..88c72413fb5 100644
--- a/dev-ruby/oauth/Manifest
+++ b/dev-ruby/oauth/Manifest
@@ -1,2 +1 @@
-DIST oauth-0.5.1.tar.gz 46675 BLAKE2B 4522326d48c9a8004819a82d23c9151ecb0b10a6f60ef57a521f8f1cf86fbfb4c3181f7a29b6f29407569da2acb6c1f5033e003a54db92586d5cd92f957d6214 SHA512 fe00e4455ab72edb38051e0c203f27b299b624cdc3ba031de9aea33c1429a54a364f066297dae86c22b723859ab8bd8854b02d344ec49a535c28b256e96593a6
DIST oauth-0.5.3.tar.gz 59355 BLAKE2B d676ca2aade85a43655ca95ff289b248c33197a06f58b5d998b834ec6750547c5b66d781f97b66b04584f6f6825d010434cb9a73cf5ec69b900a73f0dce1d8f0 SHA512 658a0b2c8b2eaa51981fd274c5058996309aa0a7098fad8221ca4074f51d996c17c5bdd8373da5e13b6cdc782b9d59769b705f2aa6ad724a2ebd14034ff92e9e
diff --git a/dev-ruby/oauth/oauth-0.5.1.ebuild b/dev-ruby/oauth/oauth-0.5.1.ebuild
deleted file mode 100644
index 1b866d8157f..00000000000
--- a/dev-ruby/oauth/oauth-0.5.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="HISTORY README.rdoc TODO"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A RubyGem for implementing both OAuth clients and servers"
-HOMEPAGE="https://github.com/oauth-xx/oauth-ruby"
-SRC_URI="https://github.com/oauth-xx/oauth-ruby/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="${PN}-ruby-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86-macos"
-IUSE=""
-
-ruby_add_bdepend "test? (
- dev-ruby/test-unit:2
- dev-ruby/mocha:1.0
- dev-ruby/webmock
- dev-ruby/rack )"
-
-all_ruby_prepare() {
- # Require a compatible version of mocha
- sed -i -e '1igem "mocha", "~> 1.0"' \
- -e '2i gem "test-unit"; require "test/unit"' \
- -e '/byebug/ s:^:#:' test/test_helper.rb || die
-
- # Remove tests that require Rails 2.3 since that is ruby18-only.
- rm -f test/test_action_controller_request_proxy.rb || die
-
- # Remove typhoeus tests since they require an old version.
- rm -f test/test_typhoeus_request_proxy.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -I.:lib -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
-}