summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2017-05-08 22:33:52 -0400
committerZero_Chaos <zerochaos@gentoo.org>2017-05-08 23:08:51 -0400
commit7957183897714578477378c56fb86e9d450863a3 (patch)
tree80a7ae0cdd8ffa62dc6c33ae696c13a28c68e29c /dev-ruby/octokit/octokit-4.7.0.ebuild
parentdev-ruby/jsobfu: drop unneeded gemspec hack (diff)
downloadgentoo-7957183897714578477378c56fb86e9d450863a3.tar.gz
gentoo-7957183897714578477378c56fb86e9d450863a3.tar.bz2
gentoo-7957183897714578477378c56fb86e9d450863a3.zip
dev-ruby/octokit: bump, tests fail in the same way as 4.6.2
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/octokit/octokit-4.7.0.ebuild')
-rw-r--r--dev-ruby/octokit/octokit-4.7.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/octokit/octokit-4.7.0.ebuild b/dev-ruby/octokit/octokit-4.7.0.ebuild
new file mode 100644
index 000000000000..6510b8100b28
--- /dev/null
+++ b/dev-ruby/octokit/octokit-4.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md CONTRIBUTING.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby toolkit for the Github API"
+HOMEPAGE="https://github.com/octokit/octokit.rb"
+SRC_URI="https://github.com/octokit/octokit.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+RUBY_S=octokit.rb-${PV}
+
+ruby_add_rdepend ">=dev-ruby/sawyer-0.8.0"
+ruby_add_bdepend "test? ( dev-ruby/mime-types
+ >=dev-ruby/netrc-0.7.7
+ dev-ruby/vcr:2
+ >=dev-ruby/webmock-1.9:0 )"
+
+all_ruby_prepare() {
+ sed -i -e "1,10d" -e "/require 'vcr'/i\gem 'vcr', '~> 2.9.2'" spec/helper.rb || die
+}