summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-25 10:10:41 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-30 08:07:25 +0200
commit54a4cbac510fa276edfe33ed66c0b6ca1918a11f (patch)
treecd139afa9ba95c0669fd338b3b7af34c007e95a9 /dev-ruby/optimist/optimist-3.1.0.ebuild
parentdev-util/rocm-cmake: drop 5.1.3, 5.3.3, 9999 (diff)
downloadgentoo-54a4cbac510fa276edfe33ed66c0b6ca1918a11f.tar.gz
gentoo-54a4cbac510fa276edfe33ed66c0b6ca1918a11f.tar.bz2
gentoo-54a4cbac510fa276edfe33ed66c0b6ca1918a11f.zip
dev-ruby/optimist: add 3.1.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/optimist/optimist-3.1.0.ebuild')
-rw-r--r--dev-ruby/optimist/optimist-3.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/optimist/optimist-3.1.0.ebuild b/dev-ruby/optimist/optimist-3.1.0.ebuild
new file mode 100644
index 000000000000..1abe03c9e1f4
--- /dev/null
+++ b/dev-ruby/optimist/optimist-3.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="FAQ.txt History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A commandline option parser for Ruby that just gets out of your way"
+HOMEPAGE="https://www.manageiq.org/optimist/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
+SLOT="3"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/chronic )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundle/ s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ MUTANT=true ${RUBY} -S rake test || die "Tests failed."
+}