summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-25 07:42:39 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-25 08:09:02 +0200
commit26cbfb39efb5541489495d7f578c6c922ba4ed56 (patch)
tree5da4b1450a2b75a7672716badd5e5f088d2fbe28 /dev-ruby/parser/parser-2.7.1.5.ebuild
parentdev-libs/efl: don't forget others than systemd or elogind on 1.25.0 (diff)
downloadgentoo-26cbfb39efb5541489495d7f578c6c922ba4ed56.tar.gz
gentoo-26cbfb39efb5541489495d7f578c6c922ba4ed56.tar.bz2
gentoo-26cbfb39efb5541489495d7f578c6c922ba4ed56.zip
dev-ruby/parser: add 2.7.1.5
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/parser/parser-2.7.1.5.ebuild')
-rw-r--r--dev-ruby/parser/parser-2.7.1.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/parser/parser-2.7.1.5.ebuild b/dev-ruby/parser/parser-2.7.1.5.ebuild
new file mode 100644
index 000000000000..83eae080a852
--- /dev/null
+++ b/dev-ruby/parser/parser-2.7.1.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_VERSION="${PV/_pre/.pre.}"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A production-ready Ruby parser written in pure Ruby"
+HOMEPAGE="https://github.com/whitequark/parser"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+="test? ( =dev-util/ragel-6* )"
+
+ruby_add_bdepend "test? (
+ dev-ruby/minitest:5
+ dev-ruby/racc
+ dev-ruby/cliver )"
+ruby_add_rdepend "=dev-ruby/ast-2.4* >=dev-ruby/ast-2.4.1"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e '/simplecov/ s:^:#:' test/helper.rb || die
+}