summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-05-27 07:11:19 +0200
committerHans de Graaff <graaff@gentoo.org>2019-05-27 07:21:32 +0200
commitf90717934d9dc778877f72e6b3054bc3b1a1ddc1 (patch)
tree3da8fd43c6c631a317d0c5c74ba4b6503b6b8901 /dev-ruby/path_expander/path_expander-1.0.4.ebuild
parentdev-ruby/hoe: add 3.18.0 (diff)
downloadgentoo-f90717934d9dc778877f72e6b3054bc3b1a1ddc1.tar.gz
gentoo-f90717934d9dc778877f72e6b3054bc3b1a1ddc1.tar.bz2
gentoo-f90717934d9dc778877f72e6b3054bc3b1a1ddc1.zip
dev-ruby/path_expander: add 1.0.4
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/path_expander/path_expander-1.0.4.ebuild')
-rw-r--r--dev-ruby/path_expander/path_expander-1.0.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/path_expander/path_expander-1.0.4.ebuild b/dev-ruby/path_expander/path_expander-1.0.4.ebuild
new file mode 100644
index 000000000000..8bca9466ad0d
--- /dev/null
+++ b/dev-ruby/path_expander/path_expander-1.0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pre-process CLI arguments expanding directories into their constituent files"
+HOMEPAGE="https://github.com/seattlerb/path_expander"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="1"
+IUSE=""
+
+all_ruby_prepare() {
+ # Fix tests depending on sort order
+ sed -i -e '/test_process_args_dir/,/^ end/ s:^:#:' \
+ -e '33 s/$/.sort/' \
+ -e '83 s/act/act.sort/' \
+ test/test_path_expander.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}