summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-09-02 08:14:21 +0200
committerHans de Graaff <graaff@gentoo.org>2016-09-02 08:14:21 +0200
commit114beb9d6d5b452e77ff3fdea9b1d66c8d61b428 (patch)
treea5ed94056e33ac2516c4bb3051ccd252a519d318 /dev-ruby/patron
parentdev-ruby/patron: cleanup (diff)
downloadgentoo-114beb9d6d5b452e77ff3fdea9b1d66c8d61b428.tar.gz
gentoo-114beb9d6d5b452e77ff3fdea9b1d66c8d61b428.tar.bz2
gentoo-114beb9d6d5b452e77ff3fdea9b1d66c8d61b428.zip
dev-ruby/patron: add 0.7.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/patron')
-rw-r--r--dev-ruby/patron/Manifest1
-rw-r--r--dev-ruby/patron/patron-0.7.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/patron/Manifest b/dev-ruby/patron/Manifest
index 0329866f5bae..879977f4a808 100644
--- a/dev-ruby/patron/Manifest
+++ b/dev-ruby/patron/Manifest
@@ -3,3 +3,4 @@ DIST patron-0.4.20.gem 42496 SHA256 eb1782f38f280a9975fc97435920c29fd10a0c2e05b6
DIST patron-0.5.0.gem 44032 SHA256 6abf431b05f560afc8c479685bb3869797522290777a1ae8510ef5c8b3208c63 SHA512 84c4cbb4ebeac3a9320915b35e4afefda5637f1bed96e83b8c2345dfd08ba02e07806b13a87c5067dd842ccddb67928c7f60889687676c0683d4e09373d8c2a7 WHIRLPOOL df34adeb59ea45d5d84a6ad1aef3e0fbf4781720443be2ba37450ddf2e51ac3b2c969bb2798fe78bb476cde79f4ccc3d3c1f6511a20dc2deda5a750ec9d03139
DIST patron-0.5.1.gem 45056 SHA256 45776b937ee788343ce4d24817460138989b1a65ad9d8d87130cf8804133444e SHA512 d47549ae1712f25e0d15bc2e1e32de6ad3084da4f0149013c4cf50dd92ccb7c01024831ef6df7c4acb78ed3923cde95e3f36a5ef8430d3f103ebb7f5906dd0fd WHIRLPOOL b766263104b67ad1ba9009e101ac027e509ed017f0b93461d8f4c9f51b8b5586dc4da080b1685b72bad837bf690ea02f709fab7a76dddd11f7450ea0e8994fca
DIST patron-0.6.5.gem 54272 SHA256 eb7ec133b4fedb240543fa96061ee52fa9ede2bcf6351d13b5cc057d6fec6935 SHA512 ffb2681b7ca062f78931d288314e563f265c9e584b3cb82af16529e8c9b578cca4d57c6e2afc506562cc946def736814b1da13a2630273551e7bf179786516cc WHIRLPOOL cda9b38b74efc0593de4c89dc4efc91ac1431b12293cd83fee32cd7aff1c85c1fcdc7b8c16f54fb0aa4dacc3901cbb37b3dfa2a9d4dd8b4f1011d1c55965efcd
+DIST patron-0.7.1.gem 54784 SHA256 aa75525e6f0064d82aacf86241f8ff381c5d8116d4199113d042b1ac8ff4b91d SHA512 bb95c98d28cc09157c05d3f39694df2b165cb72a46d54d41ca03eca992b94f579a62c081692bf81685852d46668c363e975726142622932d74fd73521414556a WHIRLPOOL f4575d4315c76425963194105b6be2b65ad498f457167312517f70f7497a0a87274466e717cc6bf1dbac9f35796ff7c484f5a147f6201347e202d5ad5db34290
diff --git a/dev-ruby/patron/patron-0.7.1.ebuild b/dev-ruby/patron/patron-0.7.1.ebuild
new file mode 100644
index 000000000000..14a12a44cf38
--- /dev/null
+++ b/dev-ruby/patron/patron-0.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl"
+HOMEPAGE="https://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND+=" net-misc/curl"
+RDEPEND+=" net-misc/curl"
+
+all_ruby_prepare() {
+ # Fix Rakefile
+ sed -i -e 's:rake/rdoctask:rdoc/task:' \
+ -e 's/README.txt/README.md/' \
+ -e '/bundler/I s:^:#:' \
+ -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/^end/ s:^:#:' \
+ Rakefile || die
+
+ # Avoid specs with failures. We were not running any specs before.
+ rm spec/session_ssl_spec.rb spec/session_spec.rb spec/response_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron V=1
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}