summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/patron
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/patron')
-rw-r--r--dev-ruby/patron/Manifest2
-rw-r--r--dev-ruby/patron/metadata.xml5
-rw-r--r--dev-ruby/patron/patron-0.4.18-r1.ebuild36
-rw-r--r--dev-ruby/patron/patron-0.4.18-r2.ebuild41
-rw-r--r--dev-ruby/patron/patron-0.4.20.ebuild44
5 files changed, 128 insertions, 0 deletions
diff --git a/dev-ruby/patron/Manifest b/dev-ruby/patron/Manifest
new file mode 100644
index 000000000000..33226609a1e3
--- /dev/null
+++ b/dev-ruby/patron/Manifest
@@ -0,0 +1,2 @@
+DIST patron-0.4.18.gem 35840 SHA256 700ffba09ea854bc26fdde08998d8310ed59b0721098d4a7dc9a85845c71bd81 SHA512 0069f42378b0dfe03e6f86003b7927b099fd15be4d4b5eeba51958774380bf7a9ddbd8a83b30942d02e95b923f9ae0a1c1abf5bcda8ca8490671208e0ae8ecb4 WHIRLPOOL c709bcd65033288fc55d8d5c044c001afa8ac34d098466e017c5adc3a08314897e86f021a09f61abcc5153893152518dc1843ba7dfa79fc271067b708283b75c
+DIST patron-0.4.20.gem 42496 SHA256 eb1782f38f280a9975fc97435920c29fd10a0c2e05b6f7a7549652ffbf92af71 SHA512 78cb97e7d7a35fb97ed7da4c767937a543c1f979c7dd1dff0d3b055024b37aa50238163af4680ba464a28523c0f5879f0d6e372276774dfdac726a5493c202e5 WHIRLPOOL a4158ac99edd2d302e59420be6d75b368e9d9d04ecd9b5051a53eb22639f3f32fa541061f28444cb716deab906c3055ddbc26c4f5289fa0c00c134517ac9ffdd
diff --git a/dev-ruby/patron/metadata.xml b/dev-ruby/patron/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/patron/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/patron/patron-0.4.18-r1.ebuild b/dev-ruby/patron/patron-0.4.18-r1.ebuild
new file mode 100644
index 000000000000..88c2d9de2c48
--- /dev/null
+++ b/dev-ruby/patron/patron-0.4.18-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl"
+HOMEPAGE="http://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+#ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+DEPEND+=" net-misc/curl"
+RDEPEND+=" net-misc/curl"
+
+# Tests require a live web service that is not included in the distribution.
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron V=1
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}
diff --git a/dev-ruby/patron/patron-0.4.18-r2.ebuild b/dev-ruby/patron/patron-0.4.18-r2.ebuild
new file mode 100644
index 000000000000..4afc70589396
--- /dev/null
+++ b/dev-ruby/patron/patron-0.4.18-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl"
+HOMEPAGE="http://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+#ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+DEPEND+=" net-misc/curl"
+RDEPEND+=" net-misc/curl"
+
+# Tests require a live web service that is not included in the distribution.
+RESTRICT="test"
+
+all_ruby_prepare() {
+ # Fix rake deprecation
+ sed -i -e 's:rake/rdoctask:rdoc/task:' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron V=1
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}
diff --git a/dev-ruby/patron/patron-0.4.20.ebuild b/dev-ruby/patron/patron-0.4.20.ebuild
new file mode 100644
index 000000000000..3658900855d1
--- /dev/null
+++ b/dev-ruby/patron/patron-0.4.20.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl"
+HOMEPAGE="http://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND+=" net-misc/curl"
+RDEPEND+=" net-misc/curl"
+
+all_ruby_prepare() {
+ # Fix Rakefile
+ sed -i -e 's:rake/rdoctask:rdoc/task:' \
+ -e 's/README.txt/README.md/' \
+ -e '/bundler/I s:^:#:' \
+ -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/^end/ s:^:#:' \
+ Rakefile || die
+
+ # Avoid specs with failures. We were not running any specs before.
+ rm spec/session_ssl_spec.rb spec/session_spec.rb spec/response_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron V=1
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}