summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-17 07:51:11 +0200
committerHans de Graaff <graaff@gentoo.org>2021-10-17 08:04:16 +0200
commit1ce3c6cb7e18cfdd76b2205ceafb3578b0349389 (patch)
tree0fa1b3cf41c4d625ff9591a2adc5d0b63c006499 /dev-ruby/pg_array_parser
parentdev-ruby/rr: add 3.0.8 (diff)
downloadgentoo-1ce3c6cb7e18cfdd76b2205ceafb3578b0349389.tar.gz
gentoo-1ce3c6cb7e18cfdd76b2205ceafb3578b0349389.tar.bz2
gentoo-1ce3c6cb7e18cfdd76b2205ceafb3578b0349389.zip
dev-ruby/pg_array_parser: EAPI 8; add ruby27, ruby30
This also drops the bundler calls that cause sandbox violations. The ebuild should already cover the correct dependencies and in general dev-ruby/* policy is to not use bundler at all to avoid additional unneeded dependencies. Closes: https://bugs.gentoo.org/688314 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/pg_array_parser')
-rw-r--r--dev-ruby/pg_array_parser/pg_array_parser-0.0.9-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/pg_array_parser/pg_array_parser-0.0.9-r3.ebuild b/dev-ruby/pg_array_parser/pg_array_parser-0.0.9-r3.ebuild
new file mode 100644
index 000000000000..eaf4ea21c240
--- /dev/null
+++ b/dev-ruby/pg_array_parser/pg_array_parser-0.0.9-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/pg_array_parser/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple library to parse PostgreSQL arrays into a array of strings"
+HOMEPAGE="https://github.com/dockyard/pg_array_parser"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/bundler"
+
+all_ruby_prepare() {
+ [ -f Gemfile.lock ] && rm Gemfile.lock
+ #if ! use development; then
+ sed -i -e "/^group :development do/,/^end$/d" Gemfile || die
+ sed -i -e "/s.add_development_dependency/d" "${PN}".gemspec || die
+ sed -i -e "/gem.add_development_dependency/d" "${PN}".gemspec || die
+ #fi
+ #if ! use test; then
+ sed -i -e "/^group :test do/,/^end$/d" Gemfile || die
+ #fi
+ #if ! use test && ! use development; then
+ sed -i -e "/^group :development, :test do/,/^end$/d" Gemfile || die
+ #fi
+}