summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-01-06 07:24:32 +0100
committerHans de Graaff <graaff@gentoo.org>2016-01-06 07:24:32 +0100
commita91d8d15581036d68a67dff597bcd217bec34347 (patch)
tree129da768fe47cf917ff9038c026f8e4f7070e1dc /dev-ruby/pkg-config/pkg-config-1.1.7.ebuild
parentapp-emulation/xen-tools: re-add deps to support x86 reported in #570974 (diff)
downloadgentoo-a91d8d15581036d68a67dff597bcd217bec34347.tar.gz
gentoo-a91d8d15581036d68a67dff597bcd217bec34347.tar.bz2
gentoo-a91d8d15581036d68a67dff597bcd217bec34347.zip
dev-ruby/pkg-config: add 1.1.7
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/pkg-config/pkg-config-1.1.7.ebuild')
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.1.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/pkg-config/pkg-config-1.1.7.ebuild b/dev-ruby/pkg-config/pkg-config-1.1.7.ebuild
new file mode 100644
index 000000000000..93633a103fd7
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.1.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+all_ruby_prepare() {
+# drop failing tests
+ sed -i -e "/test_cflags/,/end/d"\
+ -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb || die
+}