summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-01-15 08:15:31 +0100
committerHans de Graaff <graaff@gentoo.org>2018-01-15 08:15:31 +0100
commitd9ab28be9bd7ff4e291c2420dc133094ce9b19d1 (patch)
tree124ba15aca598e4006f7d12956242db0f288da3d /dev-ruby/pkg-config/pkg-config-1.2.9.ebuild
parentdev-perl/Template-DBI: EAPI6, fix for .-in-@INC failing test bug #623120 (diff)
downloadgentoo-d9ab28be9bd7ff4e291c2420dc133094ce9b19d1.tar.gz
gentoo-d9ab28be9bd7ff4e291c2420dc133094ce9b19d1.tar.bz2
gentoo-d9ab28be9bd7ff4e291c2420dc133094ce9b19d1.zip
dev-ruby/pkg-config: add 1.2.9
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/pkg-config/pkg-config-1.2.9.ebuild')
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.2.9.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/pkg-config/pkg-config-1.2.9.ebuild b/dev-ruby/pkg-config/pkg-config-1.2.9.ebuild
new file mode 100644
index 000000000000..961b61c5e574
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.2.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+all_ruby_prepare() {
+ # drop failing tests
+ sed -i -e "/test_cflags/,/end/d"\
+ -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb || die
+}