summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-01-03 08:10:01 +0100
committerHans de Graaff <graaff@gentoo.org>2021-01-03 09:05:22 +0100
commit2c9351bb739b764cfc7e5c52ce25efa40d51d9ca (patch)
tree013abdcd4f75d0dd20b0362abb5035147570a02a /dev-ruby/pkg-config/pkg-config-1.4.4.ebuild
parentdev-ruby/rubygems: add 3.2.4 (diff)
downloadgentoo-2c9351bb739b764cfc7e5c52ce25efa40d51d9ca.tar.gz
gentoo-2c9351bb739b764cfc7e5c52ce25efa40d51d9ca.tar.bz2
gentoo-2c9351bb739b764cfc7e5c52ce25efa40d51d9ca.zip
dev-ruby/pkg-config: add 1.4.4
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/pkg-config/pkg-config-1.4.4.ebuild')
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.4.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/pkg-config/pkg-config-1.4.4.ebuild b/dev-ruby/pkg-config/pkg-config-1.4.4.ebuild
new file mode 100644
index 000000000000..6ad94f426799
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.4.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test-pkg-config.rb || die
+}