summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-04-30 06:52:46 +0200
committerHans de Graaff <graaff@gentoo.org>2017-04-30 06:52:46 +0200
commit66da21ee8d5219fb887079b597c30530cb14f8a9 (patch)
tree6ac8e01acc1b9ba623b9c01a56e7d6ae6536ba2d /dev-ruby/plist/plist-3.3.0.ebuild
parentwww-client/google-chrome-beta: automated update (59.0.3071.29) (diff)
downloadgentoo-66da21ee8d5219fb887079b597c30530cb14f8a9.tar.gz
gentoo-66da21ee8d5219fb887079b597c30530cb14f8a9.tar.bz2
gentoo-66da21ee8d5219fb887079b597c30530cb14f8a9.zip
dev-ruby/plist: add 3.3.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/plist/plist-3.3.0.ebuild')
-rw-r--r--dev-ruby/plist/plist-3.3.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/plist/plist-3.3.0.ebuild b/dev-ruby/plist/plist-3.3.0.ebuild
new file mode 100644
index 000000000000..f9de0ec66eea
--- /dev/null
+++ b/dev-ruby/plist/plist-3.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library to manipulate Property List files, also known as plists"
+HOMEPAGE="https://github.com/patsplat/plist"
+SRC_URI="https://github.com/patsplat/plist/archive/v3.3.0.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}