summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-02-24 07:09:16 +0100
committerHans de Graaff <graaff@gentoo.org>2020-02-24 07:27:18 +0100
commitb94128cd287a472af1a991af31b530abb64711ff (patch)
tree9a734e94f6e506fb48b8ef3543e37e2817288ca0 /dev-ruby/power_assert/power_assert-1.1.6.ebuild
parentnet-mail/mu: revbump all due to changed RDEPENDs (diff)
downloadgentoo-b94128cd287a472af1a991af31b530abb64711ff.tar.gz
gentoo-b94128cd287a472af1a991af31b530abb64711ff.tar.bz2
gentoo-b94128cd287a472af1a991af31b530abb64711ff.zip
dev-ruby/power_assert: add 1.1.6
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/power_assert/power_assert-1.1.6.ebuild')
-rw-r--r--dev-ruby/power_assert/power_assert-1.1.6.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/power_assert/power_assert-1.1.6.ebuild b/dev-ruby/power_assert/power_assert-1.1.6.ebuild
new file mode 100644
index 000000000000..975cfd7d07d7
--- /dev/null
+++ b/dev-ruby/power_assert/power_assert-1.1.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="power_assert.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Shows each value of variables and method calls in the expression"
+HOMEPAGE="https://github.com/k-tsj/power_assert"
+SRC_URI="https://github.com/k-tsj/power_assert/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="|| ( Ruby BSD-2 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/test_helper.rb || die
+ sed -i -e '1igem "test-unit"' \
+ -e '/byebug/ s:^:#:' test/test_helper.rb || die
+
+ # Avoid git dependency
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid circular dependency on byebug when bootstrapping ruby
+ sed -i -e '/byebug/ s:^:#:' -e '/test_core_ext_helper/ s:^:#:' test/test_helper.rb || die
+ rm test/test_core_ext_helper.rb test/trace_test.rb || die
+
+ # Avoid circular dependency on pry when bootstrapping ruby
+ sed -i -e '/pry/ s:^:#:' -e '/test_colorized_pp/,/^ end/ s:^:#:' test/block_test.rb || die
+}