summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/power_assert
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/power_assert')
-rw-r--r--dev-ruby/power_assert/Manifest3
-rw-r--r--dev-ruby/power_assert/metadata.xml8
-rw-r--r--dev-ruby/power_assert/power_assert-0.2.2.ebuild24
-rw-r--r--dev-ruby/power_assert/power_assert-0.2.3.ebuild24
-rw-r--r--dev-ruby/power_assert/power_assert-0.2.4.ebuild24
5 files changed, 83 insertions, 0 deletions
diff --git a/dev-ruby/power_assert/Manifest b/dev-ruby/power_assert/Manifest
new file mode 100644
index 000000000000..060321827518
--- /dev/null
+++ b/dev-ruby/power_assert/Manifest
@@ -0,0 +1,3 @@
+DIST power_assert-0.2.2.gem 12800 SHA256 ea8146b060a4da226f5d4519cb122a6572741f5354b7cc40f74147bcbe033558 SHA512 f1bd1677734375eb03b4b9166ff84e29bd96b25e66751c4a2a305e1d9c4a63de76b7bf152a2af54871b6901230b2d2926a935aece3165a736eee1b7813e92400 WHIRLPOOL bf58578391c9b926cb38eb80d17497311f1bdb818af5f1ebb83e2ae390d594e644a38c2be14b2c49c01213dc530d239f42e40fda6b4484f4a376ef3e54ff3440
+DIST power_assert-0.2.3.gem 12800 SHA256 46dd1fa63023372da145d5fe3b58abb42c7e5f3fa4e265b7d2f5438d4e918127 SHA512 5b7604534a9fbdcd8b222d04788b375dcebed170c5c5deff2d671e54dd745474b2162c7c04e670ff8a0abda0acc6863994131f612388c2da4988f8620bb6c26f WHIRLPOOL f7bbe2fb70bc06f48a65cc78601f1fd656d6cf828888ce4e633c2cde1aca15c2ae747b07f873c44f935f51712ae6717c8925081c07163668f130afcd78c436f1
+DIST power_assert-0.2.4.gem 13312 SHA256 13f192076823f69ba1cc92978cad38f78cb9c3874eecac55c8748d539f5187d4 SHA512 542b897abd90619b74a6da38bfebec89e4e98390d78eb2c2bc98a121b0f5378b8263092bb5283f237474b089ebc3adc8461f246af16fa74e78b5757ea2215e5b WHIRLPOOL 51106eab67b2716e83844c97601ae4367d074040475d8c72770e7d9049b8288203bf592a84e280fb1af99ca8de662729cc6c1dcee28d3d0cd5d8bf4a53e91004
diff --git a/dev-ruby/power_assert/metadata.xml b/dev-ruby/power_assert/metadata.xml
new file mode 100644
index 000000000000..4d93411b119d
--- /dev/null
+++ b/dev-ruby/power_assert/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">k-tsj/power_assert</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/power_assert/power_assert-0.2.2.ebuild b/dev-ruby/power_assert/power_assert-0.2.2.ebuild
new file mode 100644
index 000000000000..0c1704ca3830
--- /dev/null
+++ b/dev-ruby/power_assert/power_assert-0.2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Shows each value of variables and method calls in the expression"
+HOMEPAGE="https://github.com/k-tsj/power_assert"
+LICENSE="|| ( Ruby BSD-2 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+SLOT="0"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' Rakefile || die
+}
diff --git a/dev-ruby/power_assert/power_assert-0.2.3.ebuild b/dev-ruby/power_assert/power_assert-0.2.3.ebuild
new file mode 100644
index 000000000000..0c1704ca3830
--- /dev/null
+++ b/dev-ruby/power_assert/power_assert-0.2.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Shows each value of variables and method calls in the expression"
+HOMEPAGE="https://github.com/k-tsj/power_assert"
+LICENSE="|| ( Ruby BSD-2 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+SLOT="0"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' Rakefile || die
+}
diff --git a/dev-ruby/power_assert/power_assert-0.2.4.ebuild b/dev-ruby/power_assert/power_assert-0.2.4.ebuild
new file mode 100644
index 000000000000..4b6cc803590c
--- /dev/null
+++ b/dev-ruby/power_assert/power_assert-0.2.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Shows each value of variables and method calls in the expression"
+HOMEPAGE="https://github.com/k-tsj/power_assert"
+LICENSE="|| ( Ruby BSD-2 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+SLOT="0"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' Rakefile || die
+}