summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-05-06 06:05:11 +0200
committerHans de Graaff <graaff@gentoo.org>2017-05-06 06:05:11 +0200
commitca7b5a4f1aee901aa27e19d6588630885d87f7b2 (patch)
treee2b2612b1742ed540a76777e76a725535f861f6d /dev-ruby/protected_attributes/protected_attributes-1.1.4.ebuild
parentdev-util/a8: remove unused version 0.11-r2. (diff)
downloadgentoo-ca7b5a4f1aee901aa27e19d6588630885d87f7b2.tar.gz
gentoo-ca7b5a4f1aee901aa27e19d6588630885d87f7b2.tar.bz2
gentoo-ca7b5a4f1aee901aa27e19d6588630885d87f7b2.zip
dev-ruby/protected_attributes: add 1.1.4
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/protected_attributes/protected_attributes-1.1.4.ebuild')
-rw-r--r--dev-ruby/protected_attributes/protected_attributes-1.1.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/protected_attributes/protected_attributes-1.1.4.ebuild b/dev-ruby/protected_attributes/protected_attributes-1.1.4.ebuild
new file mode 100644
index 000000000000..99231a4a360d
--- /dev/null
+++ b/dev-ruby/protected_attributes/protected_attributes-1.1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protect attributes from mass-assignment in ActiveRecord models"
+HOMEPAGE="https://github.com/rails/protected_attributes"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="1"
+
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_rdepend "
+ =dev-ruby/activemodel-4*:* >=dev-ruby/activemodel-4.0.1:*
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ =dev-ruby/actionpack-4*
+ =dev-ruby/activerecord-4*
+ =dev-ruby/rails-4*
+ dev-ruby/mocha
+ dev-ruby/sqlite3
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/github/ s:^:#:' Gemfile || die
+}