summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-02-13 07:16:42 +0100
committerHans de Graaff <graaff@gentoo.org>2018-02-13 07:16:42 +0100
commit92d1a13b6908ee13a8d7a95703ce9579d1cdda3e (patch)
tree2a0bb05889b3a4967d8ec15829d0600f4aae63ab /dev-ruby/public_suffix/public_suffix-3.0.2.ebuild
parentdev-python/bpython: bump to 0.17.1 (diff)
downloadgentoo-92d1a13b6908ee13a8d7a95703ce9579d1cdda3e.tar.gz
gentoo-92d1a13b6908ee13a8d7a95703ce9579d1cdda3e.tar.bz2
gentoo-92d1a13b6908ee13a8d7a95703ce9579d1cdda3e.zip
dev-ruby/public_suffix: add 3.0.2
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/public_suffix/public_suffix-3.0.2.ebuild')
-rw-r--r--dev-ruby/public_suffix/public_suffix-3.0.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/public_suffix/public_suffix-3.0.2.ebuild b/dev-ruby/public_suffix/public_suffix-3.0.2.ebuild
new file mode 100644
index 000000000000..e4f112b174ff
--- /dev/null
+++ b/dev-ruby/public_suffix/public_suffix-3.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parse and decompose a domain name into top level domain, domain and subdomains"
+HOMEPAGE="https://simonecarletti.com/code/publicsuffix-ruby/"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+LICENSE="MIT"
+SLOT="3"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/rubocop/I s:^:#:' \
+ -e '/yardoc/,/CLOBBER.include/ s:^:#:' \
+ -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e '/reporters/I s:^:#:' test/test_helper.rb || die
+}