summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-08-10 05:33:13 +0200
committerHans de Graaff <graaff@gentoo.org>2019-08-10 05:33:13 +0200
commit93fcd56c0979dcb61748e2273db66414588cd200 (patch)
tree0c501871aaa002e6083dff80ebc5f1613843ade3 /dev-ruby/public_suffix/public_suffix-4.0.1.ebuild
parentwww-apps/nanoc: add 4.11.8 (diff)
downloadgentoo-93fcd56c0979dcb61748e2273db66414588cd200.tar.gz
gentoo-93fcd56c0979dcb61748e2273db66414588cd200.tar.bz2
gentoo-93fcd56c0979dcb61748e2273db66414588cd200.zip
dev-ruby/public_suffix: add 4.0.1
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/public_suffix/public_suffix-4.0.1.ebuild')
-rw-r--r--dev-ruby/public_suffix/public_suffix-4.0.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/public_suffix/public_suffix-4.0.1.ebuild b/dev-ruby/public_suffix/public_suffix-4.0.1.ebuild
new file mode 100644
index 000000000000..dbf7b8c559eb
--- /dev/null
+++ b/dev-ruby/public_suffix/public_suffix-4.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parse and decompose a domain name into top level domain, domain and subdomains"
+HOMEPAGE="https://simonecarletti.com/code/publicsuffix-ruby/"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+LICENSE="MIT"
+SLOT="4"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/rubocop/I s:^:#:' \
+ -e '/yardoc/,/CLOBBER.include/ s:^:#:' \
+ -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e '/reporters/I s:^:#:' test/test_helper.rb || die
+}