summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-03-21 15:02:08 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-03-21 15:02:08 +0100
commit7d966990e5a7f94e14097b9cf5127c8918e91ea4 (patch)
tree34bd309db6ebf8d69c4ca0727998caddf2b21c72 /dev-ruby/pundit/pundit-1.1.0.ebuild
parentsys-fs/owfs: arm stable (bug 601148). (diff)
downloadgentoo-7d966990e5a7f94e14097b9cf5127c8918e91ea4.tar.gz
gentoo-7d966990e5a7f94e14097b9cf5127c8918e91ea4.tar.bz2
gentoo-7d966990e5a7f94e14097b9cf5127c8918e91ea4.zip
dev-ruby/pundit: Initial version
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/pundit/pundit-1.1.0.ebuild')
-rw-r--r--dev-ruby/pundit/pundit-1.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/pundit/pundit-1.1.0.ebuild b/dev-ruby/pundit/pundit-1.1.0.ebuild
new file mode 100644
index 000000000000..5af21aa346fe
--- /dev/null
+++ b/dev-ruby/pundit/pundit-1.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Object oriented authorization for Rails applications"
+HOMEPAGE="https://github.com/elabs/pundit https://rubygems.org/gems/pundit"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-3.0.0"
+
+ruby_add_bdepend "test? ( >=dev-ruby/actionpack-3.0.0
+ >=dev-ruby/activemodel-3.0.0 )"
+
+all_ruby_prepare() {
+ sed -i -e "/pry/d" spec/spec_helper.rb || die
+}