summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-12-22 07:50:22 +0100
committerHans de Graaff <graaff@gentoo.org>2022-12-23 08:48:44 +0100
commit8711a4c1be01456e77a32ad0a856cf305f47c2a1 (patch)
tree2d8e30e1f8d7cfbbf7547457b2d4ae5fbbdd7622 /dev-ruby/pundit
parentsys-devel/clang: don't gate ieee-long-double behind USE=ppc64 (diff)
downloadgentoo-8711a4c1be01456e77a32ad0a856cf305f47c2a1.tar.gz
gentoo-8711a4c1be01456e77a32ad0a856cf305f47c2a1.tar.bz2
gentoo-8711a4c1be01456e77a32ad0a856cf305f47c2a1.zip
dev-ruby/pundit: add 2.3.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/pundit')
-rw-r--r--dev-ruby/pundit/Manifest1
-rw-r--r--dev-ruby/pundit/pundit-2.3.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/pundit/Manifest b/dev-ruby/pundit/Manifest
index f2719fbc1480..13a73dda8e46 100644
--- a/dev-ruby/pundit/Manifest
+++ b/dev-ruby/pundit/Manifest
@@ -1 +1,2 @@
DIST pundit-2.2.0.gem 27136 BLAKE2B 560843f9e1d19c551ee9bdeb3ead856a483dff68187da20c463fd01cbf1ca68f48adf6d4b9589b2c755cf6c860fba98b3719af8732e9f4c284c7dc4b2a1b2f5b SHA512 fcb8c9305e7ce9301142bd62c08856ee29cf5227d63ae36ccc894c4a3b19ec9c03625c3742890e9aeabc2fc8877a5d9527d28ecc8084103bcfa8321d87458a44
+DIST pundit-2.3.0.gem 27136 BLAKE2B 651f008426ce010c8a5be8543cde5c91f1bb8c6513e08cde4c4fda965fa95647f130d0a68094107be0b0c639ab520a74da0c2a50715ec5bd86a7a9243cf53686 SHA512 5a2c8563ab8402d3454afae499368b06d0a7ce23b59fdade3034da06604b025a567c4f9bc745bbc8a51226d768fad99b9057ff38c2930258d943265053a09636
diff --git a/dev-ruby/pundit/pundit-2.3.0.ebuild b/dev-ruby/pundit/pundit-2.3.0.ebuild
new file mode 100644
index 000000000000..0720a534a031
--- /dev/null
+++ b/dev-ruby/pundit/pundit-2.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Object oriented authorization for Rails applications"
+HOMEPAGE="https://github.com/elabs/pundit https://rubygems.org/gems/pundit"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-3.0.0:*"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/actionpack-3.0.0
+ >=dev-ruby/activemodel-3.0.0
+ >=dev-ruby/railties-3.0.0
+)"
+
+all_ruby_prepare() {
+ sed -i -e "/pry/d" -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}