summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-02-21 07:20:44 +0100
committerHans de Graaff <graaff@gentoo.org>2020-02-21 07:26:49 +0100
commitc2772802ca2ae0f03700d324dc52b4f1cb5bdbe9 (patch)
tree2442c5177aa421541120ccc26382880156311a7b /dev-ruby/puppet_forge/puppet_forge-2.3.3.ebuild
parentdev-ruby/gettext-setup: add ruby27 (diff)
downloadgentoo-c2772802ca2ae0f03700d324dc52b4f1cb5bdbe9.tar.gz
gentoo-c2772802ca2ae0f03700d324dc52b4f1cb5bdbe9.tar.bz2
gentoo-c2772802ca2ae0f03700d324dc52b4f1cb5bdbe9.zip
dev-ruby/puppet_forge: add 2.3.3
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/puppet_forge/puppet_forge-2.3.3.ebuild')
-rw-r--r--dev-ruby/puppet_forge/puppet_forge-2.3.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/puppet_forge/puppet_forge-2.3.3.ebuild b/dev-ruby/puppet_forge/puppet_forge-2.3.3.ebuild
new file mode 100644
index 000000000000..abdaf707c6dd
--- /dev/null
+++ b/dev-ruby/puppet_forge/puppet_forge-2.3.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL=locales
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tools to access Forge API information on Modules, Users, and Releases"
+HOMEPAGE="https://github.com/puppetlabs/forge-ruby"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/faraday-0.9.0:0
+ >=dev-ruby/faraday_middleware-0.9.0:0
+ >=dev-ruby/gettext-setup-0.11:0
+ dev-ruby/minitar
+ =dev-ruby/semantic_puppet-1*
+"
+
+all_ruby_prepare() {
+ # Avoid integration and user specs since they all require network access
+ rm -rf spec/integration spec/unit/forge/v3/user_spec.rb || die
+
+ # Fix overly restrictive dependencies
+ sed -i \
+ -e '/faraday/ s/0.18.0/0.99.0/' \
+ -e '/faraday_middleware/ s/0.14.0/0.99.0/' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}