summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-10-14 14:00:44 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-10-14 14:01:03 -0500
commitb1784d5148a9cd90425d5a2f09f6da837c132cb5 (patch)
treeee4551400d8600fe2d802960d02805b4504da1b2 /dev-ruby/puppetdb-termini/puppetdb-termini-7.7.0.ebuild
parentapp-admin/puppetserver: 7.4.1 bump (diff)
downloadgentoo-b1784d5148a9cd90425d5a2f09f6da837c132cb5.tar.gz
gentoo-b1784d5148a9cd90425d5a2f09f6da837c132cb5.tar.bz2
gentoo-b1784d5148a9cd90425d5a2f09f6da837c132cb5.zip
dev-ruby/puppetdb-termini: 7.7.0 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/puppetdb-termini/puppetdb-termini-7.7.0.ebuild')
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-7.7.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-7.7.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-7.7.0.ebuild
new file mode 100644
index 000000000000..a7cef96b4b13
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-7.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="https://puppet.com/docs/puppetdb/latest/index.html"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}