summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-06-22 13:30:20 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-06-22 13:33:59 -0500
commit4ed9e5b0e2799df308782c8a40ede4245e0e24ec (patch)
tree140f25f7400859d06cd7302c4a381959901ceb70 /dev-ruby/puppetdb-termini
parentapp-admin/puppetdb: 6.3.3 bump (diff)
downloadgentoo-4ed9e5b0e2799df308782c8a40ede4245e0e24ec.tar.gz
gentoo-4ed9e5b0e2799df308782c8a40ede4245e0e24ec.tar.bz2
gentoo-4ed9e5b0e2799df308782c8a40ede4245e0e24ec.zip
dev-ruby/puppetdb-termini: 6.3.3 bump
Package-Manager: Portage-2.3.66, Repoman-2.3.15 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-6.3.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 658dedc54767..48614c341b48 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,2 +1,3 @@
DIST puppetdb-termini_5.2.7-1xenial_all.deb 20560 BLAKE2B def7bb25badadd2880589d5708e8b9a0f87033977a21ee65fca7b27caf8c3568c66cf7f21123ecd8dd037e29023e65a9393d8b3608ffe0e021f9aad5a8c66755 SHA512 b5a5b4c721a35d95093d9da757f5a2dcfcc232343b6ca6dcf7184a20f9ff305a9c2f04328e17a0e02579d6ee7245c7c9b7e9ba8d22bc8f3bc1c13cf50c784101
DIST puppetdb-termini_6.3.2-1stretch_all.deb 20662 BLAKE2B 2e7daef3892070d5356ced070544099a546e4887b5654f795e06952862e4c0cb155df200806217fd5376b1bc3fb53107467ca76acec05283d2f25fed7ca7e5ca SHA512 555abacc9de7221df78a8459a76a4c3c8ce3a1bf5e2b6f1d800761eaea650d2a308e6a5054be082cfb9823903fbe049b2dc5f323b8af93693afbb61c8ce6c4be
+DIST puppetdb-termini_6.3.3-1stretch_all.deb 20676 BLAKE2B ba66e1eb57d7a95977974ef73d19927566b9de21077bd4907462b922d79194e5af46fc579bf7a36763f65e0a35c90e8ebb648b25b9ac9cdc3f8b5bb4eb76c52c SHA512 d584815f25fe19c4c1f0d3033dcb2d3dfc985f74e757d7ea6cf40171186cda5ab2e042942063475a0144daa9dbbb0d2e82cb800a842ad61b505b36c5c3c8cb3c
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-6.3.3.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-6.3.3.ebuild
new file mode 100644
index 000000000000..6d51b944dfdb
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-6.3.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}