summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rack-attack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rack-attack')
-rw-r--r--dev-ruby/rack-attack/Manifest2
-rw-r--r--dev-ruby/rack-attack/metadata.xml8
-rw-r--r--dev-ruby/rack-attack/rack-attack-4.2.0.ebuild32
-rw-r--r--dev-ruby/rack-attack/rack-attack-4.3.0.ebuild32
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/rack-attack/Manifest b/dev-ruby/rack-attack/Manifest
new file mode 100644
index 000000000000..b79a2ade2233
--- /dev/null
+++ b/dev-ruby/rack-attack/Manifest
@@ -0,0 +1,2 @@
+DIST rack-attack-4.2.0.gem 15360 SHA256 f915f0811e32455729b58a1f4359a31a169f6a465ac46e163e573eb4cbca918e SHA512 27a46987d864886ba5f2a2724fb36293f3d7bc6721d1663defaa924bc6e3e17dd3f74b260eb74e0f6ca84a331dfeaea6431d0589b2cb410a51385d96c27cfca9 WHIRLPOOL 136fed76ce46865294f1f0952c564a5799728855166b1f1ef5d96fbea6dc1fa0f76bd3e33e6c3a9c3aa1b3197f00deca09ca153aeb4b1c03764c174eb1905677
+DIST rack-attack-4.3.0.gem 15360 SHA256 d9f588dcf44f4e767c304354b6699302b1297da09c263a2172daab31eeee651b SHA512 000149f3c80f5642082585f0c2b25c80d5cd7416db45374defa662205efe2972949ed3d701f7f0baa27cbcf3114e85143820400f998ec089c4129258b8338443 WHIRLPOOL 85ccebba19f691cd989a6fcf18959ed5177691467e8314e160c9845f3bebe9eaf3f634b29dd4a1f21fc1463538060b3b68cc4f74bc0db9a3f092e8e3230ac64b
diff --git a/dev-ruby/rack-attack/metadata.xml b/dev-ruby/rack-attack/metadata.xml
new file mode 100644
index 000000000000..b7a0f2c2ffd3
--- /dev/null
+++ b/dev-ruby/rack-attack/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">kickstarter/rack-attack</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rack-attack/rack-attack-4.2.0.ebuild b/dev-ruby/rack-attack/rack-attack-4.2.0.ebuild
new file mode 100644
index 000000000000..286d2dae963e
--- /dev/null
+++ b/dev-ruby/rack-attack/rack-attack-4.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# Skip integration tests since they require additional unpackaged
+# dependencies and running daemons.
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A DSL for blocking & throttling abusive clients"
+HOMEPAGE="https://github.com/kickstarter/rack-attack"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/rack"
+ruby_add_bdepend "test? ( dev-ruby/activesupport
+ dev-ruby/rack-test
+ dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' Rakefile spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/rack-attack/rack-attack-4.3.0.ebuild b/dev-ruby/rack-attack/rack-attack-4.3.0.ebuild
new file mode 100644
index 000000000000..ab16a0b6b91d
--- /dev/null
+++ b/dev-ruby/rack-attack/rack-attack-4.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# Skip integration tests since they require additional unpackaged
+# dependencies and running daemons.
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A DSL for blocking & throttling abusive clients"
+HOMEPAGE="https://github.com/kickstarter/rack-attack"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/rack:*"
+ruby_add_bdepend "test? ( dev-ruby/activesupport
+ dev-ruby/rack-test
+ dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' Rakefile spec/spec_helper.rb || die
+}