summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-02-19 07:18:39 +0100
committerHans de Graaff <graaff@gentoo.org>2018-02-19 07:18:39 +0100
commit25a639e3c23d0ac69f7c5b62bb75e5d32aacd14f (patch)
tree64cdd0e17ce4f55d64bea6b6921d26b48e70d305 /dev-ruby/rack-protection/rack-protection-2.0.1.ebuild
parentdev-php/PEAR-Text_CAPTCHA: Drop old (diff)
downloadgentoo-25a639e3c23d0ac69f7c5b62bb75e5d32aacd14f.tar.gz
gentoo-25a639e3c23d0ac69f7c5b62bb75e5d32aacd14f.tar.bz2
gentoo-25a639e3c23d0ac69f7c5b62bb75e5d32aacd14f.zip
dev-ruby/rack-protection: add 2.0.1
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/rack-protection/rack-protection-2.0.1.ebuild')
-rw-r--r--dev-ruby/rack-protection/rack-protection-2.0.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/rack-protection-2.0.1.ebuild b/dev-ruby/rack-protection/rack-protection-2.0.1.ebuild
new file mode 100644
index 000000000000..58c4ac881ee6
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-2.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"