summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-24 09:35:11 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-24 09:35:11 +0200
commitac119814ca8607934eb57f794a09f45cf7d40929 (patch)
treeb6c7a3a7216f2aaf25effe3b96daf8241368c571 /dev-ruby/rack-protection
parentdev-ruby/nokogiri: add 1.13.8 (diff)
downloadgentoo-ac119814ca8607934eb57f794a09f45cf7d40929.tar.gz
gentoo-ac119814ca8607934eb57f794a09f45cf7d40929.tar.bz2
gentoo-ac119814ca8607934eb57f794a09f45cf7d40929.zip
dev-ruby/rack-protection: add 2.2.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rack-protection')
-rw-r--r--dev-ruby/rack-protection/Manifest1
-rw-r--r--dev-ruby/rack-protection/rack-protection-2.2.2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
index aaffbbc57a4c..49812e12289d 100644
--- a/dev-ruby/rack-protection/Manifest
+++ b/dev-ruby/rack-protection/Manifest
@@ -1,2 +1,3 @@
DIST rack-protection-2.2.0.gem 17408 BLAKE2B d9d5d8e2473b6354dd61cfc338a05932a2c60aa12544399cb0b9b74c717d6fa48bdec638381582be0a13f845f0c69583275f412458a20198894b5eddc7b53358 SHA512 06d6c2026e3e93131a2405bbaa8a514ddde48607979828b9fc41309dbdfff2b7c8cac48a6981e76b5dda554f0cbdc7c6ff5f44b8925fce1cb9b7de0a16380ca4
DIST rack-protection-2.2.1.gem 17408 BLAKE2B 21ecf95a27ab08b2e89369cfaffff43192c2ca5bb74afe7a91041e5fb9f2479a625ca2fcc59fc2f3eb208f17a3456dffd14095d25f8a0ed331972f6f987dace6 SHA512 595dc7ff7deb63130f966a12849750900319356f29948e9cca1e1aebe168bad77de624dd280a1b804ad6a2d44daedfcb352777ca724e9fde2a5de02ead472734
+DIST rack-protection-2.2.2.gem 17408 BLAKE2B d67384374afa29712742531bff0cca78be96f80dd316d4e5929cb2751152bc0d73f8ede4430aa50a2e114b872845f11ca8debe93eaa1a7a63e05daae697c2e7d SHA512 6bc7694daebcc2fb585b303aa059e82db94c142a82d0e951e0dd99388074449c989d41c3aa05882a150776e28d0394f78d0b063e564e7eda7aea14d496eef0fb
diff --git a/dev-ruby/rack-protection/rack-protection-2.2.2.ebuild b/dev-ruby/rack-protection/rack-protection-2.2.2.ebuild
new file mode 100644
index 000000000000..d31bdbd997d7
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-2.2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"