summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-12-25 07:34:35 +0100
committerHans de Graaff <graaff@gentoo.org>2019-12-25 07:34:35 +0100
commitdc7278d897e9d02e1db533ed94e0ad6af676b858 (patch)
treee7272077485f4ec9236b5b7e681f397628b395ac /dev-ruby/rb-inotify/rb-inotify-0.10.1.ebuild
parentdev-ruby/did_you_mean: add 1.4.0 (diff)
downloadgentoo-dc7278d897e9d02e1db533ed94e0ad6af676b858.tar.gz
gentoo-dc7278d897e9d02e1db533ed94e0ad6af676b858.tar.bz2
gentoo-dc7278d897e9d02e1db533ed94e0ad6af676b858.zip
dev-ruby/rb-inotify: add 0.10.1
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rb-inotify/rb-inotify-0.10.1.ebuild')
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.10.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.10.1.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.10.1.ebuild
new file mode 100644
index 000000000000..fd890af7d202
--- /dev/null
+++ b/dev-ruby/rb-inotify/rb-inotify-0.10.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thorough inotify wrapper for Ruby using FFI"
+HOMEPAGE="https://github.com/nex3/rb-inotify"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/ffi"
+
+ruby_add_bdepend "test? ( dev-ruby/concurrent-ruby )"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on jeweler.
+ sed -i -e '/:build/ s:^:#:' -e '/module Jeweler/,/^end/ s:^:#:' -e '/class Jeweler/,/^end/ s:^:#:' Rakefile || die
+
+ # Remove mandatory markup processor from yard options, bug 436112.
+ sed -i -e '/maruku/d' .yardopts || die
+
+ sed -i -e '/bundler/ s:^:#:' -e '1irequire "pathname"' spec/spec_helper.rb || die
+}