summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-12-16 07:35:36 +0100
committerHans de Graaff <graaff@gentoo.org>2018-12-16 07:35:36 +0100
commit9d8b61964edede957a780f6614e16581468b56da (patch)
tree745216456655536aa2c63343d750b6760d2f483d /dev-ruby/rb-inotify
parentwww-servers/civetweb: fix mixed use of tabs and spaces (diff)
downloadgentoo-9d8b61964edede957a780f6614e16581468b56da.tar.gz
gentoo-9d8b61964edede957a780f6614e16581468b56da.tar.bz2
gentoo-9d8b61964edede957a780f6614e16581468b56da.zip
dev-ruby/rb-inotify: add 0.10.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/rb-inotify')
-rw-r--r--dev-ruby/rb-inotify/Manifest1
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.10.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/rb-inotify/Manifest b/dev-ruby/rb-inotify/Manifest
index 0e1b72c2f5ff..b95fc991f74c 100644
--- a/dev-ruby/rb-inotify/Manifest
+++ b/dev-ruby/rb-inotify/Manifest
@@ -1 +1,2 @@
+DIST rb-inotify-0.10.0.gem 15872 BLAKE2B 52647ff17994287810efa9c04bc9553b101c42cdd27cf42d530565127dfce104a589ad729d7019409079731577d327221ec3423fa7a5f746aefa3d817b93d898 SHA512 16aa7fb21e5ed713335e583299cfc72676e3ef66de3d349f74a14885b88020b79e031839b193dc140036a0b6539a45ef3a0c3c6027a7211508d388137d22a13b
DIST rb-inotify-0.9.10.gem 14848 BLAKE2B 35eb00dfe1e7e76fddda080499275c053e82431af520170362354984cb2af3c90e3ba803ef82fe50f1451d3fdb0ddb7ef9c1dc648836403a6865396987d6d9c2 SHA512 ee1aecfebea11655450776013d8d2fa3fb2af784285db3c32b5a452241f9cd48a8f9a10cb2f1ff96b191c0dcd43ec4f78e8a363447abf97a8cd4ccb778de4889
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.10.0.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.10.0.ebuild
new file mode 100644
index 000000000000..05e307428f60
--- /dev/null
+++ b/dev-ruby/rb-inotify/rb-inotify-0.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thorough inotify wrapper for Ruby using FFI"
+HOMEPAGE="https://github.com/nex3/rb-inotify"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/ffi"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on jeweler.
+ sed -i -e '/:build/ s:^:#:' -e '/module Jeweler/,/^end/ s:^:#:' -e '/class Jeweler/,/^end/ s:^:#:' Rakefile || die
+
+ # Remove mandatory markup processor from yard options, bug 436112.
+ sed -i -e '/maruku/d' .yardopts || die
+
+ sed -i -e '/bundler/ s:^:#:' -e '1irequire "pathname"' spec/spec_helper.rb || die
+}