summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-11-26 07:33:47 +0100
committerHans de Graaff <graaff@gentoo.org>2018-11-26 07:33:47 +0100
commitc535e0dcd20ac631df3bc7b831c8054f2ab2c71f (patch)
tree8f1bd5d618f1627cfeb86d84ee74dca1407feecf /dev-ruby/rbnacl/rbnacl-6.0.0.ebuild
parentdev-ruby/em-websocket: fix FEATURES=test and dependencies (diff)
downloadgentoo-c535e0dcd20ac631df3bc7b831c8054f2ab2c71f.tar.gz
gentoo-c535e0dcd20ac631df3bc7b831c8054f2ab2c71f.tar.bz2
gentoo-c535e0dcd20ac631df3bc7b831c8054f2ab2c71f.zip
dev-ruby/rbnacl: add 6.0.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/rbnacl/rbnacl-6.0.0.ebuild')
-rw-r--r--dev-ruby/rbnacl/rbnacl-6.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/rbnacl/rbnacl-6.0.0.ebuild b/dev-ruby/rbnacl/rbnacl-6.0.0.ebuild
new file mode 100644
index 000000000000..8b66c427ccb4
--- /dev/null
+++ b/dev-ruby/rbnacl/rbnacl-6.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a high-level toolkit for building cryptographic systems and protocols"
+HOMEPAGE="https://github.com/cryptosphere/rbnacl"
+
+LICENSE="MIT"
+SLOT="6"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND+=" dev-libs/libsodium"
+DEPEND+=" test? ( dev-libs/libsodium )"
+
+ruby_add_rdepend "dev-ruby/ffi"
+
+all_ruby_prepare() {
+ sed -i -e '/coveralls/I s:^:#:' \
+ -e '/bundler/ s:^:#:' \
+ -e 's:rbnacl/libsodium:rbnacl:' spec/spec_helper.rb
+}