summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-09-09 07:40:07 +0200
committerHans de Graaff <graaff@gentoo.org>2019-09-09 07:40:07 +0200
commitc5cc0d85baea4bc5233308215b81ad681c9ba993 (patch)
tree40557224f35bc2b2ddedc9cce6c9fc6696b3acd0 /dev-ruby/rbnacl/rbnacl-7.1.0.ebuild
parentdev-ruby/maxitest: amd64 stable (diff)
downloadgentoo-c5cc0d85baea4bc5233308215b81ad681c9ba993.tar.gz
gentoo-c5cc0d85baea4bc5233308215b81ad681c9ba993.tar.bz2
gentoo-c5cc0d85baea4bc5233308215b81ad681c9ba993.zip
dev-ruby/rbnacl: add 7.1.0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rbnacl/rbnacl-7.1.0.ebuild')
-rw-r--r--dev-ruby/rbnacl/rbnacl-7.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rbnacl/rbnacl-7.1.0.ebuild b/dev-ruby/rbnacl/rbnacl-7.1.0.ebuild
new file mode 100644
index 000000000000..e947ec005c6e
--- /dev/null
+++ b/dev-ruby/rbnacl/rbnacl-7.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a high-level toolkit for building cryptographic systems and protocols"
+HOMEPAGE="https://github.com/cryptosphere/rbnacl"
+
+LICENSE="MIT"
+SLOT="6"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND+=" dev-libs/libsodium"
+DEPEND+=" test? ( dev-libs/libsodium )"
+
+ruby_add_rdepend "dev-ruby/ffi"
+
+all_ruby_prepare() {
+ sed -i -e '/coveralls/I s:^:#:' \
+ -e '/bundler/ s:^:#:' \
+ -e 's:rbnacl/libsodium:rbnacl:' spec/spec_helper.rb
+}