summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-04-13 07:05:49 +0200
committerHans de Graaff <graaff@gentoo.org>2022-04-13 07:05:49 +0200
commit21234e260083f7e5df10ba80744b373f37dc60e0 (patch)
tree5c0cd8a6dcee8a172b8aa5035f000d3071473852 /dev-ruby/redcloth
parentdev-ruby/rake-compiler: add 1.1.9 (diff)
downloadgentoo-21234e260083f7e5df10ba80744b373f37dc60e0.tar.gz
gentoo-21234e260083f7e5df10ba80744b373f37dc60e0.tar.bz2
gentoo-21234e260083f7e5df10ba80744b373f37dc60e0.zip
dev-ruby/redcloth: drop 4.3.2-r2, 4.3.2-r3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/redcloth')
-rw-r--r--dev-ruby/redcloth/redcloth-4.3.2-r2.ebuild61
-rw-r--r--dev-ruby/redcloth/redcloth-4.3.2-r3.ebuild61
2 files changed, 0 insertions, 122 deletions
diff --git a/dev-ruby/redcloth/redcloth-4.3.2-r2.ebuild b/dev-ruby/redcloth/redcloth-4.3.2-r2.ebuild
deleted file mode 100644
index e87b4a1a74b6..000000000000
--- a/dev-ruby/redcloth/redcloth-4.3.2-r2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_NAME="RedCloth"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGELOG"
-
-RUBY_FAKEGEM_REQUIRE_PATHS="lib/case_sensitive_require"
-
-RUBY_FAKEGEM_GEMSPEC=redcloth.gemspec
-
-inherit ruby-fakegem
-
-DESCRIPTION="A module for using Textile in Ruby"
-HOMEPAGE="http://redcloth.org/"
-
-GITHUB_USER=jgarber
-SRC_URI="https://github.com/${GITHUB_USER}/redcloth/archive/v${PV}.tar.gz -> ${RUBY_FAKEGEM_NAME}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND+=" =dev-util/ragel-6*"
-
-PATCHES=( "${FILESDIR}/${P}-load-documents.patch" )
-
-ruby_add_bdepend "
- >=dev-ruby/rake-0.8.7
- >=dev-ruby/rake-compiler-0.7.1
- test? ( >=dev-ruby/diff-lcs-1.1.2 )"
-
-pkg_setup() {
- ruby-ng_pkg_setup
-
- # Export the VERBOSE variable to avoid remapping of stdout and
- # stderr, and that breaks because of bad interactions between
- # echoe, Ruby and Gentoo.
- export VERBOSE=1
-}
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' Rakefile ${PN}.gemspec || die
- rm -f tasks/{release,rspec,rvm}.rake || die
-}
-
-each_ruby_compile() {
- # We cannot run this manually easily, because Ragel re-generation
- # is a mess
- ${RUBY} -S rake compile || die "rake compile failed"
-}
diff --git a/dev-ruby/redcloth/redcloth-4.3.2-r3.ebuild b/dev-ruby/redcloth/redcloth-4.3.2-r3.ebuild
deleted file mode 100644
index 79aadcf980a1..000000000000
--- a/dev-ruby/redcloth/redcloth-4.3.2-r3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_NAME="RedCloth"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGELOG"
-
-RUBY_FAKEGEM_REQUIRE_PATHS="lib/case_sensitive_require"
-
-RUBY_FAKEGEM_GEMSPEC=redcloth.gemspec
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/redcloth_scan/extconf.rb)
-
-inherit ruby-fakegem
-
-DESCRIPTION="A module for using Textile in Ruby"
-HOMEPAGE="http://redcloth.org/"
-
-GITHUB_USER=jgarber
-SRC_URI="https://github.com/${GITHUB_USER}/redcloth/archive/v${PV}.tar.gz -> ${RUBY_FAKEGEM_NAME}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND+=" =dev-util/ragel-6*"
-
-PATCHES=( "${FILESDIR}/${P}-load-documents.patch" )
-
-ruby_add_bdepend "
- >=dev-ruby/rake-0.8.7
- >=dev-ruby/rake-compiler-0.7.1
- test? ( >=dev-ruby/diff-lcs-1.1.2 )"
-
-pkg_setup() {
- ruby-ng_pkg_setup
-
- # Export the VERBOSE variable to avoid remapping of stdout and
- # stderr, and that breaks because of bad interactions between
- # echoe, Ruby and Gentoo.
- # export VERBOSE=1
-}
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' Rakefile ${PN}.gemspec || die
- rm -f tasks/{release,rspec,rvm}.rake || die
-}
-
-each_ruby_prepare() {
- ${RUBY} -S rake ext/redcloth_scan/extconf.rb || die
-}